Symptom
Sie hören beim Spielen der Tasten des KOMPLETE KONTROL S-Series Keyboards keinen Sound und es ist in den KOMPLETE KONTROL Preferences nicht als MIDI-Gerät verfügbar.
Ursache
Das Problem kann folgende Ursachen haben:
- Die Systemdienste NIHardwareAgent und/oder NIHostIntegrationAgent laufen nicht.
- Die MIDI-Inputs des Keyboards sind ausgeschaltet.
- Das Keyboard ist nicht korrekt angeschlossen.
- Nur Mac: Ein Plug-in im HAL-Ordner verhindert, dass das Keyboard erkannt wird.
- Nur Windows: Der Treiber des Keyboards ist nicht richtig installiert.
Lösung
Folgen Sie diesen Schritten, um das Problem zu beheben:
- Stellen Sie sicher, dass die Dienste NIHardwareAgent und NIHostIntegrationAgent auf Ihrem Computer laufen. Folgen Sie diesen Schritten für Mac oder Windows:
Mac
- Öffnen Sie die Systemeinstellungen Ihres Macs und wählen Sie Benutzer & Gruppen > Anmeldeobjekte.
- Wenn die Objekte NIHardwareAgent und/oder NIHostIntegrationAgent in der Liste fehlen, fügen Sie diese hinzu, indem Sie den Button '+' klicken und zu folgendem Ordner navigieren:
Mac HD > Library > Application Support > Native Instruments > Hardware - Wählen Sie den fehlenden Service aus und klicken Sie Hinzufügen:
Hinweis: Sie können beide Dienste auswählen, indem Sie die SHIFT-Taste gedrückt halten und beide Einträge anklicken.
Windows
- Öffnen Sie den Task Manager und wählen Sie den Tab Dienste.
Hinweis: Sollte der Tab Dienste nicht nicht angezeigt werden, klicken Sie auf Mehr Details in der unteren linken Ecke des Fensters.
- Durchsuchen Sie die Liste und überprüfen Sie, ob der Status der Dienste NIHostIntegrationAgent und NIHardwareService als Wird ausgeführt angezeigt wird:
- Wenn der Dienst nicht ausgeführt wird, rechtsklicken Sie auf den Eintrag und wählen Sie Starten aus dem Kontextmenü:
- Öffnen Sie die Systemeinstellungen Ihres Macs und wählen Sie Benutzer & Gruppen > Anmeldeobjekte.
- Aktivieren Sie die MIDI Input-Anschlüsse Ihres Keyboards:
- Öffnen Sie in KOMPLETE KONTROL die Preferences und wählen Input im Tab MIDI.
- Mac: Stellen Sie sicher, dass die Inputs aktiviert sind. Sollte ein Input nicht mit einem Häkchen gekennzeichnet sein, klicken Sie in das Quadrat, um den Input zu aktivieren:
- Windows: Stellen Sie sicher, dass die Inputs aktiviert sind. Sollte ein Input nicht mit einem Häkchen gekennzeichnet sein, klicken Sie in das Quadrat, um den Input zu aktivieren:
- Benutzen Sie, wenn vorhanden, das mitgelieferte, originale USB-Kabel des Keyboards. Verbinden Sie das Kabel direkt mit Ihrem Computer. Wenn Sie einen USB-Hub benutzen müssen, stellen Sie sicher, dass dieser über eine eigene Stromversorgung verfügt.
- Nur Mac: Um herauszufinden, ob ein Plug-in im HAL-Ordner die Erkennung des Keyboards verhindert, folgen Sie der Anleitung in diesem Artikel.
- Nur Windows: Um sicherzustellen, dass der Treiber des Keyboards korrekt installiert ist, folgen Sie der Anleitung in Kapitel 1 und 2 in diesem Artikel.