Symptom
Mein NI-Programm stürzt ab, wenn ich versuche, es zu starten.
Hinweis: Wenn Native Access beim Starten abstürzt oder einfriert, lies bitte diesen Artikel. Die folgenden Informationen können jedoch auch zur weiteren Fehlerbehebung bei Startproblemen von Native Access verwendet werden.
Ursache
Dieses Problem kann durch verschiedene Faktoren verursacht werden. Unten sind die häufigsten Lösungen für Startabstürze auf Windows-Computern aufgeführt.
Lösungen
Klicke die Links, um die aufgeführten Lösungen zu erweitern:
1. Löschen der User-Registry
- Klicke unten links auf deinem Desktop auf den Windows-Startbutton.
- Gib "regedit" ein und drücke die Enter-Taste, um den Registry-Editor zu öffnen.
- Navigiere im Registry-Editor zu folgendem Pfad und lösche den Ordner des Produkts, das abstürzt:
HKEY_CURRENT_USER > Software > Native Instruments > *Produktname*-Ordner
Achte darauf, NUR den oben genannten Ordner zu löschen. Das Löschen des falschen Ordners könnte dazu führen, dass die zugehörige Anwendung nicht korrekt funktioniert.
- Schließe den Registry-Editor und versuche noch einmal, das NI-Programm zu öffnen.
2. Reinitialisierung der Database
- Navigiere im Windows Datei-Explorer zu folgendem Ordner:
C: > Benutzer > Benutzername > AppData > Local > Native Instruments
Hinweis: "AppData" ist ein versteckter Ordner. Lies bitte diesen Artikel, um zu erfahren, wie du diesen anzeigen kannst. - Lösche den Ordner des Produkts, das beim Starten abstürzt.
- Versuche noch einmal, das NI-Programm zu starten.
3. Windows-Updates installieren
- Klicke den Windows-Startbutton und gib "windows updates" ein. Drücke die Enter-Taste.
- Klicke auf den Button Nach Updates suchen.
- Installiere alle verfügbaren Updates.
- Starte deinen Computer neu, wenn alle Updates installiert sind.
- Versuche noch einmal, das NI-Programm zu starten.
4. Aktualisierung des Grafikkarten-Treibers
Der einfachste Weg, um nach Updates für deinen Grafikkarten-Treiber zu suchen, ist über die Website des Herstellers. Um den Namen und das Modell deiner Grafikkarte herauszufinden, führe die folgenden Schritte aus:
- Klicke den Windows-Startbutton, gib "gerätemanager" ein und drücke die Enter-Taste.
- Doppelklicke auf Grafikkarten, um das Grafikkarten-Menü zu öffnen.
In unserem Beispiel sehen wir, dass der Computer über eine NVIDIA NVS 310-Grafikkarte verfügt. - Besuche die Webseite des Herstellers. In unserem Beispiel wäre das NVDIA.
- Lade von der Website des Herstellers den neuesten Treiber für deine Grafikkarte herunter und installiere ihn.
5. Monitor-Einstellungen
In seltenen Fällen können die Bildschirmeinstellungen des Monitors bei NI-Anwendungen Probleme verursachen. Bitte versuche Folgendes:
- Wenn du zwei Monitore angeschlossen hast, versuche, einen davon abzuziehen.
- Verwende eine normale Skalierung für die Auflösung deines Monitors. Wenn die Skalierung zu hoch konfiguriert ist, kann sie das Öffnen der NI-Anwendung verhindern. Führe die folgenden Schritte aus, um die Skalierung zu konfigurieren:
- Klicke den Windows-Startbutton, gib "Einstellungen" ein und drücke die Enter-Taste, um die Windows-Einstellungen zu öffnen
- Wähle System.
- Klicke auf Anzeige.
- Öffne unter Skalierung und Anordnung das Dropdown-Menü und wähle die empfohlene Skalierung aus:
-
Versuche noch einmal, das NI-Programm zu starten.
6. Antivirus-Einstellungen
In einigen seltenen Fällen kann es vorkommen, dass eine Antiviren-Software das Öffnen einer NI-Anwendung stört. Versuche, die Antiviren-Software vorübergehend zu deaktivieren oder die NI-Anwendung zur Ausnahmeliste der Antiviren-Software hinzuzufügen.
7. Administrator-Modus
Abhängig von der Einrichtung deines Windows-Systems kann es notwendig sein, die NI-Anwendung im Administrator-Modus zu öffnen. Folge diesen Schritten:
- Rechtsklicke das Desktopsymbol der NI-Anwendung (oder die entsprechende ".exe"-Datei in deinem Programme-Ordner).
- Wähle Eigenschaften.
- Aktiviere im Reiter Kompatibilität die Option Programm als Administrator ausführen.
- Klicke zur Bestätigung OK.
Die NI-Anwendung wird nun immer im Administrator-Modus ausgeführt. Versuche, sie erneut zu starten.
8. Soundkarten-Einstellungen
Wenn die Anwendung versucht, den Treiber für die On-Board-Soundkarte deines Computers zu laden, während für die einzelnen Ausgänge deiner Soundkarte(n) unterschiedliche Abtastraten (Samplerates) eingestellt sind, kann dies zum Absturz der NI-Anwendung führen.
Stelle sicher, dass die Abtastrate für alle einzelnen Ein- und Ausgänge deiner Soundkarten gleich ist:
- Klicke den Windows Start-Button, gib "systemsound" ein und drücke die Enter-Taste.
- Klicke im Reiter Wiedergabe auf einen der Einträge und wähle Eigenschaften.
- Öffne im Eigenschaften-Fenster den Reiter Erweitert.
- Überprüfe die Abtastrate. In unserem Beispiel unter Punkt 6 ist eine Abtastrate von 44.100 Hz festgelegt.
- Wiederhole diesen Vorgang für alle Einträge im Reiter Wiedergabe und stelle sicher, dass du für alle Ausgänge (Outputs) dieselben Einstellungen für die Samplerate festlegst.
- Nachdem du alle Ausgänge eingestellt hast, wiederhole den Vorgang für alle im Reiter Aufnahme angezeigten Eingänge (Inputs).
- Versuche noch einmal, das NI-Programm zu starten.
9. Aktualisieren der Treiber für Audio-Interface / Soundkarte
Stelle sicher, dass du die neuste Treiberversion für dein Audio-Interface verwendest. Du findest den aktuellen Treiber auf der Webseite des Herstellers. Nachdem du den neusten Treiber installiert hast, starte deinen Computer neu und versuche, das NI-Programm zu starten.