Symptom
Während der Installation eines NI-Produkts schlägt der Installationsprozess fehl und es wird die folgende Fehlermeldung angezeigt:
NI InstallAware Plugin
FATAL ERROR: Can't write...
Ursache
Einige Windows-Systemdateien, die für die Installation eines NI-Produktes benötigt werden, sind möglicherweise beschädigt.
Lösungen
1. Zurücksetzen Ihres Installationsorders:
- Navigieren Sie zu folgendem Ordner:
C: > Benutzer > *Benutzername* > AppData > Local > TempHinweis: Der 'Temp'-Ordner ist standardmäßig versteckt. In diesem Artikel erfahren Sie, wie Sie versteckte Ordner anzeigen.
- Wählen Sie alle Dateien und Ordner im 'Temp'-Ordner aus, indem Sie Strg + A auf Ihrer Tastatur drücken.
- Löschen Sie alle ausgewählten Elemente, indem Sie mit der rechten Maustaste klicken und im Kontextmenü Löschen wählen. Beachten Sie, dass einige Dateien und Ordner nicht gelöscht werden können.
Wenn diese Lösung nicht hilft, fahren Sie fort:
2. Microsofts 'Systemdatei-Überprüfungsprogramm'
Führen Sie Microsofts 'Systemdatei-Überprüfungsprogramm' durch, wie in diesem Microsoft-Artikel erklärt.
Wenn diese Lösung nicht hilft, fahren Sie fort:
3. Kürzen der Dateipfadlänge
Das Problem kann auch auftreten, wenn der gesamte Pfad, in dem die Installationsdateien erstellt werden, die in Windows definierte maximale Länge überschreitet. Stellen Sie sicher, dass der Pfad zum Speichern Ihrer Content-Produkte so kurz wie möglich ist:
- Öffnen Sie in Native Access die Preferences.
- Wählen Sie unter File locations einen anderen Pfad als Content location aus. Stellen Sie dabei sicher, dass der Pfad so kurz wie möglich ist. In unserem Beispiel setzen wir den Pfad auf D:/Tools/NI, der viel kürzer ist, als der vorher festgelegte Pfad 'D: > Tools > Music > Native Instruments > Content' (siehe Screenshot der Fehlermeldung oben).
- Installieren Sie das Produkt erneut.