Symptom
Beim Versuch, ein Produkt mit Native Access zu installieren, erscheint folgende Fehlermeldung:
Downloading (*Product*) failed: could not create new file or truncate existing file
Ursache
Dieser Fehler erscheint, wenn in den Preferences in Native Access nicht-kompatible Speicherorte für Download oder Installation festgelegt wurden.
Lösung
Die folgenden Punkte müssen bei der Auswahl benutzerdefinierter Speicherorte beachtet werden:
- Für jeden Speicherort in den Preferences muss ein eigener Ordner festgelegt werden.
- Virtuelle oder Cloud-Laufwerke können nicht als Speicherort ausgewählt werden.
- Das Root-Laufwerk kann nicht als Speicherort ausgewählt werden.
Beispiel 1
In der Abbildung unten hat der Benutzer seine externe Festplatte als Download-Speicherort festgelegt. Während dies generell in Ordnung ist, muss ein bestimmter Ordner auf dieser Festplatte ausgewählt werden. Das Root-Verzeichnis selbst kann nicht ausgewählt werden. In diesem Fall sollte der richtige Speicherort /Volumes/Sandisk 480/Downloads sein. Die anderen Speicherorte in diesem Beispiel sind korrekt festgelegt.
Beispiel 2
Hier hat der Benutzer als Download-Verzeichnis den Plug-in-Ordner angegeben. Da dies nicht funktioniert, muss auch hier ein eigener Download-Ordner festgelegt werden (z.B. /Benutzer/*Benutzername*/Downloads).
Darüberhinaus wurde für Application und Content derselbe Speicherote angegeben. Doch auch hier müssen unterschiedliche Ordner festgelegt werden. Die standardmäßig voreingestellten Ordner sind Programme/Native Instruments and /Benutzer/Öffentlich (Windows) bzw. /Benutzer/Geteilt (Mac).