Symptom
Beim Versuch, ein Produkt mit Native Access zu installieren, wird die folgende Fehlermeldung angezeigt:
Installation failed
macOS
Ursache
Dieses Problem tritt auf, wenn Native Access nicht über die erforderlichen Berechtigungen verfügt, um die Installation abzuschließen.
Lösung
- Öffne die Systemeinstellungen von deinem Mac und klicke auf Sicherheit.
- Öffne den Reiter Datenschutz und wähle links im Menü Festplattenvollzugriff aus.
- Klicke unten links auf das Schloss-Symbol (falls verfügbar) und gib dein Mac-Passwort ein.
- Stelle sicher, dass Native Access und NTKDaemon in der Liste angezeigt werden und aktiviert sind.
Sollten sie nicht angezeigt werden, klicke das "+" Symbol und füge folgenden Programme hinzu:
- Macintosh HD: Programme > Native Access
- Macintosh HD > Library > Application Support > Native Instruments > NTK > NTKDaemon
Wenn du versuchst, Komplete Kontrol oder Maschine zu installieren, füge auch NIHardwareAgent hinzu:
- Macintosh HD > Library > Application Support > Native Instruments > Hardware > NIHArdwareAgent - Klicke nach Abschluss erneut auf das Schloss-Symbol (falls verfügbar).
Je nachdem, welches macOS du verwendest, kann die Darstellung variieren. Im Zweifelsfall schaue bitte nach, wie man Full Disk Access auf deinem eigenen macOS öffnet. Neuere Versionen sehen wie folgt aus: - Starte deinen Computer neu und starte Native Access.
Die Installation funktioniert nun korrekt in Native Access.
Windows
Ursache
Das Problem kann verschiedene Ursachen haben. Hier besprechen wir die häufigsten:
Lösungen
Es wird ein falscher / nicht unterstützter Dateipfad verwendet
Eine häufige Ursache für dieses Problem ist, dass ein nicht unterstützter Dateipfad in den Native Access Preferences hinzugefügt wurde. Um dies zu testen, probiere Folgendes aus:
- Starte Native Access und öffne Preferences > File Management.
- Klicke Restore Defaults.
- Schließe die Preferences und versuche die Installation erneut.
Wenn die Installation nun wie erwartet funktioniert, war entweder ein ausgewählter Dateipfad falsch, oder der Speicherort kann nicht beschrieben werden. Dies könnte das Ergebnis eines falsch formatierten/beschädigten externen Laufwerks oder eines Problems mit den Berechtigungen sein.
Achte bei der Installation mit Native Access immer darauf, dass ein Ordner für die Installation ausgewählt wird und nicht ein Stammverzeichnis. Die Installation in den Speicherort D:\ funktioniert beispielsweise nicht, während der Speicherort D:\NI Libraries problemlos funktionieren sollte.
Stelle außerdem sicher, dass bei Application Location immer der Standard-Pfad C:\Program Files\Native Instruments\ eingtragen ist. Eine Pfad-Änderung wird hier nicht unterstützt.
Eine frühere Installation ist fehlerhaft / beschädigt
Dies geschieht in der Regel, wenn eine Produktinstallation unterbrochen wurde, bevor sie abgeschlossen wurde, und das Installationsprogramm die vorherige Version nicht deinstallieren kann.
Die Schritte zur Lösung findest du in der folgenden Anleitung: Probleme mit Software-Updates beheben (Windows)
Starte danach die Installation in Native Access erneut.
Die Windows-Installation ist beschädigt oder es fehlen notwendige Dateien.
Manchmal können Windows-Installationen beschädigt werden, was zu Installationsfehlern und allgemeinen Nutzungsproblemen führt. In solchen Fällen kann dies mit den folgenden Tools von Microsoft überprüft oder repariert werden:
- Verwenden des Systemdatei-Überprüfungsprogramms (SFC.exe) zur Problembehandlung bei fehlenden oder beschädigten Systemdateien
- Beheben von Windows Update-Beschädigungen und Installationsfehlern
Nutze den Download Manager zur manuellen Installation
Wenn das Problem weiterhin auftritt, probiere bitte, das Installationsprogramm manuell über unseren neuen Download Manager herunterzuladen und dann auszuführen.
Starte Native Access nach Abschluss der manuellen Installation, um dein Produkt automatisch zu aktivieren.