Symptom
Mein Native Instruments-Programm stürzt ab, wenn ich versuche, es zu starten.
Hinweis: Wenn Native Access beim Starten abstürzt oder einfriert, lies bitte diesen Artikel. Die folgenden Informationen können jedoch auch zur weiteren Fehlerbehebung bei Startproblemen von Native Access verwendet werden.
Ursache
Dieses Problem kann durch verschiedene Faktoren verursacht werden. Unten sind die häufigsten Lösungen für Startabstürze auf Mac-Systemen aufgeführt.
Lösungen
1. Aktivierung des Festplattenvollzugriffs
Es kann notwendig sein, deiner NI-Anwendung Festplattenvollzugriff zu gewähren, damit sie korrekt funktioniert. Weitere Informationen zum Festplattenvollzugriff findest du auf dieser Apple-Website.
- Öffne die Systemeinstellungen von deinem Mac und klicke auf Sicherheit.
- Öffne den Reiter Datenschutz und wähle links im Menü Festplattenvollzugriff aus.
- Klicke unten links auf das Schloss-Symbol und gib dein Mac-Passwort ein.
- Stelle sicher, dass die jeweilige NI-Anwendung in der Liste angezeigt wird.
Wenn sie nicht in der Liste erscheint, klicke das "+" Symbol und füge den Pfad der Anwendung hinzu. Z.B. für Maschine 2:
Mac HD: Programme > Native Instruments > Maschine 2 > Maschine 2.app. - Klicke nach Abschluss erneut auf das Schloss-Symbol.
2. Reinitialisiere die Application Support Database
- Gehe zu folgendem Ordner:
Macintosh HD > Benutzer > *Benutzername* > Library > Application Support > Native Instruments
Hinweis: Die User-Library ist ein versteckter Ordner. Um auf sie zuzugreifen, klicke in der Finder-Menüleiste auf "Gehe zu" und halte die 'Alt'-Taste gedrückt. Nun kannst du "Library" im Menü auswählen.
- Durchsuche den Native Instruments-Ordner nach dem Ordner, der zu dem Produkt gehört, das abstürzt.
- Lösche den jeweiligen Produkt-Ordner.
Hinweis: Lösche keine anderen Ordner! Das Löschen anderer Ordner kann zu unerwartetem Verhalten deiner Anwendungen führen.
- Starte das NI-Produkt erneut, um zu prüfen, ob das Problem behoben wurde.
3. Löschen der User-PLIST-Datei
- Öffne Finder und navigiere zu folgendem Ordnerr:
Macintosh HD > Benutzer > *Benutzername* > Library > Preferences
Hinweis: Die User-Library ist ein versteckter Ordner. Um auf sie zuzugreifen, klicke in der Finder-Menüleiste auf "Gehe zu" und halte die 'Alt'-Taste gedrückt. Nun kannst du "Library" im Menü auswählen.
- Durchsuche den Preferences-Ordner nach dem plist-Eintrag, der zu deinem Produkt gehört, das abstürzt. Der Eintrag hat folgendes Format:
com.native-instruments.*Produktname*.plist - Lösche die plist-Datei des jeweiligen Produktes.
Hinweis: Lösche keine anderen plist-Dateien! Das Löschen anderer plist-Dateien kann zu unerwartetem Verhalten deiner Anwendungen führen.
- Starte das NI-Produkt erneut, um zu prüfen, ob das Problem behoben wurde.
4. Neuinstallation der NI-Software
Wenn die oben aufgeführten Lösungen das Problem nicht behoben haben, versuche, die NI-Software, die abstürzt, vollständig zu entfernen und neu zu installieren.
Hinweis: Die Deinstallation / Neuinstallation hat keine Auswirkungen auf deine DAW-Projekte oder gespeicherten Dokumente. Eine Neuinstallation auf demselben Computer wirkt sich nicht auf die zulässige Anzahl von Aktivierungen aus (weitere Informationen finden Sie in diesem Artikel).
- In diesem Artikel findest du detaillierte Anweisungen zum manuellen Entfernen der abstürzenden NI-Anwendung.
Hinweis: In den meisten Fällen ist es nicht notwendig, einen Kontakt-Library-Ordner zu löschen, um gängige Probleme zu beheben.
- Nachdem die NI-Anwendung entfernt wurde, kann sie über den Reiter Available in Native Access wieder neu installiert werden.