Note: If you are on Mac OS X 10.10 (and higher) or Windows 7 (and higher), you can also use the Repair function in Native Access as explained in this article.
Symptom
You receive this error message when trying to load a preset from the MASCHINE 2 Browser:
Missing Product
Cause
You receive this error message if the mentioned product's Factory Library cannot be found in its original location. Usually this happens if the name of the hard drive that contains the Library has changed or the Library has been moved.
Solution
- Open MASCHINE's Preferences and select Library > Factory.
- Click on the folder icon of the product's entry.
- Navigate to the Library's current location and confirm the selection.
- Click the Rescan button in the Preferences window.
- You can close the Preferences now.
Alternative Solutions
- You can repair the Library with Native Access as shown in this article.
- If the name of the hard drive has changed, you can rename it to the original name that is shown in Preferences > Library > Factory.
- If you have moved the Library, you can move it back to the original location that is shown in Preferences > Library > Factory