Symptom
When starting your KOMPLETE KONTROL software, the keyboard doesn't react as expected. In this case, its display remains black.
Causes
This behavior can be caused by different factors. Click the possible causes one by one to be redirected to the corresponding troubleshooting steps below in the article.
- The KOMPLETE KONTROL software is not up to date.
- The services NIHardwareAgent or NIHostIntegrationAgent are not running in the background.
- The HAL plug-in directory in the System Library folder contains drivers which are not supported.
- The computer's system drive is formatted in a case-sensitive format.
- There is an issue with the USB connection.
Solutions
1. The KOMPLETE KONTROL software is not up to date
Install the latest version of KOMPLETE KONTROL from the Not installed tab in Native Access. If your operating system does not support the latest software update, you can download an earlier compatible version from the Update Manager.
2. The services NIHardwareAgent or NIHostIntegrationAgent are not running in the background.
Make sure that both the NIHardwareAgent and the NIHostIntegrationAgent applications are set as startup items.
- Open your Mac's System Preferences and choose Users & Groups.
- Make sure your account is selected under Current User and go to the Login Items tab. Verify if both NIHardwareAgent and NIHostIntegrationAgent are listed in the login items.
- If any of these two items are missing in the list, add them by clicking the '+' icon.
- Navigate to the following location:
Mac HD > Library > Application Support > Native Instruments > Hardware - Select the missing service and click Add:
Note: If the services are missing from the Hardware folder, please reinstall KOMPLETE KONTROL's latest update. Read chapter 1.3 - "Downloading and Installing a Software Product Update from the UPDATES Page" of this article to obtain more information. Make sure to disconnect your KOMPLETE KONTROL keyboard from your system during installation.
The NIHardwareAgent and NIHostIntegrationAgent services are now set as a login items. Restart your computer, start the KOMPLETE KONTROL software and check if your KOMPLETE KONTROL keyboard starts as expected. If this is not the case, continue troubleshooting.
3. The HAL plug-in folder contains drivers which are not supported
Your Hal plug-in folder in the System Library folder may contain a driver which prevents the KOMPLETE KONTROL keyboard from starting correctly. Follow this article's instructions to troubleshoot this issue. If your KOMPLETE KONTROL keyboard is still not working properly, continue troubleshooting:
4. The computer's system drive is formatted in a case-sensitive format.
Case-sensitive hard drive formats are not supported by Native Instruments products and will prevent the KOMPLETE KONTROL keyboard to start as expected. This article explains how to find out if your hard drive's format is case-sensitive. If it is not, continue troubleshooting.
5. The USB cable or the USB hub is not supported.
Use the original USB cable provided with your KOMPLETE KONTROL keyboard. If not available anymore, this article contains information which will help you choose a suitable USB cable.
If possible, always connect your KOMPLETE KONTROL keyboard directly to your computer's USB port. If you must use a USB-hub, make sure it has its own power supply.