Symptom
A Native Instruments software application crashes at startup.
Note: If Native Access is crashing or freezing when attempting to open it, please check this article. However, the information below can also be used to further troubleshoot Native Access startup issues.
Cause
This behaviour can have different causes. These troubleshooting steps list the most common solutions to NI software startup crashes on Windows computers.
Solutions
Click to expand the solutions listed below.
1. Delete the USER Registry Entry
- Click the Windows Start button at the bottom left side of your screen.
- Type "regedit" into the search field, then press Enter to open the Windows Registry Editor.
- In the Registry Editor, navigate the folder structure to this location and locate the folder for the NI product that is crashing:
HKEY_CURRENT_USER > Software > Native Instruments > *Product Name* Folder
- Delete only the folder for the NI product that is crashing.
Note: Deleting the incorrect folder could result in unexpected behaviour with other applications, and possibly your operating system.
- Close the Registry Editor and reopen your NI software to check that the issue has been resolved.
2. Reinitialize the Application Database
- In the Windows File Explorer, go to the following location:
C: > Users > "Your Username" > AppData > Local > Native Instruments
Note: The "AppData" is a hidden Windows folder. See this article for instructions to display hidden Windows folders.
- Search through the Native Instruments folder at this location to find the folder of the NI product that is crashing.
- Delete only the folder for the NI product that is crashing.
- Reopen your NI software to check that the issue has been resolved.
3. Update Windows
- Click the Windows Start button at the bottom left side of your screen.
- Type 'windows updates' into the search field, then press Enter.
- Install all available updates presented in the Windows Update menu.
- Once all Windows updates have been installed, restart the computer.
- Reopen your NI software to check that the issue has been resolved.
4. Update the Graphics Card Driver
The quickest way to check for Graphics Card Updates is on the manufacturer's website. To find the name and model of your graphics card, follow these steps:
- Click the Windows Start button at the bottom left side of your screen.
- Type 'device manager' into the search field, then press Enter.
- Double click Display adapters in the list to open the drop-down menu.
Note: In the example above, we see the computer has an Intel (R) HD Graphics 3000 graphics card.
- Visit the website of your graphics card manufacturer (in this example, Intel).
- From the manufacturer's website, download and install the latest driver for your graphics card model.
- Once your graphics card driver has been updated, reopen your NI software to check that the issue has been resolved.
5. Monitor Settings
In some rare cases, a display monitor's screen setting may cause problems with NI software applications.
- If using two monitor screens, please try disconnecting one of them from the computer.
-
Use the main monitor's default scaling.
Note: If the scaling is configured too high it may prevent the NI application from opening.
Now, follow these steps to configure the monitor scaling:
- Click the Windows Start button at the bottom left side of your screen.
- Type in 'Settings' into the search field, then press Enter.
- In the Settings app, choose System.
- On the left panel, click Display.
- Under the Scale and layout section, use the drop-down menu to select the scale setting labeled: 100% (Recommend)
- Reopen your NI software to check that the issue has been resolved.
6. Antivirus Settings
In some rare cases, antivirus software may interfere with the launch of an NI application. Try temporarily disabling the antivirus software, or try adding your NI application to the exception list of your antivirus program.
Note: Please check the documentation for your antivirus software or contact the antivirus manufacturer if further assistance with its configuration is needed.
Once you have made the necessary adjustments to your antivirus software, reopen your NI software to check that the issue has been resolved.
7. Administrator Mode
Depending on the setup of your Windows system, it may be necessary to open an application in Administrator mode. Please proceed with these steps:
- Right-click the NI application icon on your desktop, or the app-icon (.exe) in the program folder:
C: > Program Files > Native Instruments - Choose Properties.
- On the Compatibility tab, tick the box next to: Run This Program As An Administrator
- Click OK to confirm.
- Now the NI software will always run in Administrator mode. Reopen your NI software to check that the issue has been resolved.
8. Sound Card Settings
Your NI software may crash if you try to launch it with the driver for your computer's built-in sound card, while different sample rates are set for the sound card's individual outputs.
Make sure the sample rate settings are the same for all individual inputs and outputs of your sound card:
- Click the Windows Start button at the bottom left side of your screen.
- Type in 'sound settings' into the search field, then press Enter.
- On the left panel, click Sound (see below).
- Choose your main sound card or audio interface device from the Output drop menu. In this example, a Komplete Audio 6 MK2 is used.
Note: Be sure to perform these steps with all of the entries (if present) within the Output drop menu, as these separate entries represent all outputs available on your soundcard / audio interface device(s).
- Click Device Properties, underneath the drop menu where you selected your audio interface.
- On the Device Properties page, click Additional device properties.
- In the pop-up window (e.g. Output 1/2 Properties), click the Advanced tab.
- Check the sample rate. Here the sample rate is set to 2 channel, 24 bit, 44.100 Hz (Studio Quality). Click OK once your selection is made.
- Go back to the main sound settings page and repeat this process (steps 4-8 above) for all remaining device entries in the Output drop menu. Be sure to choose the exact same sample rate settings for all outputs and sound card devices.
- After configuring all of the output entries repeat this whole procedure for all input entries on the main sound settings page.
- Reopen your NI software to check that the issue has been resolved.
9. Update the Sound Card / Audio Interface Drivers
Make sure that the driver (and possibly the firmware) of your sound card is up to date by checking the manufacturer's website for the last available driver and firmware.
Once the driver is installed, reboot your system and reopen your NI software to check that the issue has been resolved.