Symptom
When starting your MASCHINE 2 software, the controller freezes and the displays do not react to the software or show only 'Maschine / Groove Production Studio'.
Causes
This behavior can be caused by different factors. Click the possible causes one by one to be redirected to the corresponding troubleshooting steps below:
- The MASCHINE software is not up to date.
- The HAL plug-in folder contains drivers which are not supported.
- The NIHardwareAgent is not running in the background.
- The MASCHINE hardware was powered on before the computer (MASCHINE MK3 and STUDIO only)
- Your MASCHINE model is not supported by current Mac systems.
- The computer's system drive is formatted in a case-sensitive format.
- There is an issue with the USB connection.
Solutions
1. The MASCHINE software is not up to date
Download and install the latest version of MASCHINE from the Not installed tab in Native Access. If your operating system does not support the latest software update, you can download the corresponding compatible version from here.
2. The HAL plug-in folder contains drivers which are not supported
Your MASCHINE controller may not start when an outdated version of the AVID CoreAudio plug-in is installed under OS X 10.10.5 or higher. The solutions are as follows:
2.1. Update the AVID CoreAudio Driver
In most cases the issue will be fixed after the installation of the latest update of the AVID CoreAudio Driver. If installing the latest update of the AVID CoreAudio Driver is not an option or the issue persists, please continue:
2.2. Removing the Avid CoreAudio Plug-in
Disclaimer: This procedure describes the manual uninstallation of a third-party manufacturer component. Native Instruments cannot be held responsible for any damages to your system caused by following these instructions.
- Open Finder and navigate to the folder:
Macintosh HD > Library > Audio > Plug-Ins > HAL - Copy the "Avid CoreAudio.plugin" to another location, for example the Desktop.
- Delete the "Avid CoreAudio.plugin" from the HAL Plug-in folder.
- Type in the admin password when prompted.
- Restart your computer.
While you can fully use Pro Tools without the Avid CoreAudio plug-in, it is not possible to monitor the audio output of any CoreAudio application using your Avid HD audio interface after removing the file. If you should require this functionality again, move the file back to its original location in the HAL folder and restart your computer.
2.3 Updating / Removing Other Plug-ins
If there are more ".plug-in" files in this folder, visit the manufacturer's website and install the latest updates for these plug-ins. Should the problem persist, try temporarily removing the ".plugin" files from the HAL folder as explained in step 2 above.
3. The NIHardwareAgent is not running in the background.
Make sure that the NIHardwareAgent application is set as startup item.
- Open your Mac's System Preferences and choose Users & Groups.
- Make sure your account is selected under Current User and go to the Login Items tab. Verify if the the NIHardwareAgent is listed in the login items.
- If the file NIHardwareAgent is missing in the list, add it by clicking the '+' icon.
- Navigate to the following location:
Mac HD > Library > Application Support > Native Instruments > Hardware - Select the missing service and click Add:
The NIHardwareAgent is now set as a login item. Restart your computer, start the MASCHINE software and check if your controller starts as expected. If this is not the case, continue troubleshooting.
4. The MASCHINE hardware was powered on before the computer (MASCHINE MK3 and STUDIO only)
The correct sequence to connect and power up your device is:
- Switch on your computer.
- Connect your MASCHINE MK3 or STUDIO (if it is not already connected).
- Press the power switch on the rear panel of the controller to switch it on.
5. Your MASCHINE model is not supported by current Mac systems
There are three different MASCHINE controller models. If you are using the first-generation MASCHINE MK1 (out of production), it might not be recognized by your Mac system as it is no longer supported on macOS 10.12 (Sierra) or later. The MASCHINE MK1 model is pictured below:
Although it is not officially supported, the following workaround might help you get it running on macOS 10.12 or higher:
- Delete the Maschine Controller Driver .plist file:
Macintosh HD > Library > Preferences > com. native-instruments.Maschine Controller.plist - Delete the "NIUSBMaschineController" file from here:
Macintosh HD > System > Library > Extensions - Restart your computer.
- Install the 2.8.0 driver Maschine driver again. You will find the "MASCHINE Controller Driver 2.8.0 - Mac OS X 10.9 - 10.11" from the Drivers & Other Files page of our website.
- Additional step for macOS 10.13 or higher: once the driver's installation is finished, open the Apple Preferences and navigate to Security & Privacy option. Accept, if you are requested to "ALLOW" the Native Instruments driver here.
6. The computer's system drive is formatted in a case-sensitive format.
Case-sensitive hard drive formats are not supported by Native Instruments products and will prevent the MASCHINE controller to start as expected. This article explains how to find out if your hard drive's format is case-sensitive. If it is not, continue troubleshooting.
7. The USB cable or the USB hub is not supported.
Use the original USB cable provided with your MASCHINE controller. If not available anymore, this article contains information which will help you choose a suitable USB cable.
If possible, always connect your MASCHINE controller directly to your computer's USB port. If you must use a USB-hub, make sure it has its own power supply.