Symptom
When trying to load a preset from the MASCHINE 2 Browser, you receive the following error message mentioning a particular Native Instruments product:
Error: *NI Product* could not be loaded.
Cause
When loading a preset from the Instrument section of the MASCHINE Browser, you actually load a plug-in (eg. FM8, MASSIVE, REAKTOR, etc.) which generates the sound of the preset. Additionally, many presets from the Instrument section of the Browser belong to KONTAKT Libraries or REAKTOR Ensembles.
The above error message indicates that the plug-in of the NI product or of KONTAKT/REAKTOR is not found in its original installation path.
Solution
Reinstall the NI Product
- Open Native Access.
- Go to the Installed products tab and scroll down to the NI product mentioned in the error message. Hover your mouse over FULL VERSION until you see a REINSTALL button. Press it to launch the reinstallation process.
Now, load the preset again in MASCHINE. If you still get the same error message, make sure both KONTAKT (or KONTAKT Player if you do not own the full version) and REAKTOR (or REAKTOR Player if you do not own the full version) are correctly installed. Please continue with the troubleshooting steps below.
Reinstall KONTAKT and REAKTOR
- Open Native Access.
- Go to the Installed products tab and scroll down to Kontakt 5 (or Kontakt Player).
- If they do not appear at all in the list, go to the Not installed tab and install it.
- Hover your mouse over FULL VERSION until you see a REINSTALL button. Press it to launch the reinstallation process.
- Go to the Installed products tab and scroll down to Reaktor 6 Application (or Reaktor Player).
- If they do not appear at all in the list, go to the Not installed tab and install it.
- Hover your mouse over FULL VERSION until you see a REINSTALL button. Press it to launch the reinstallation process.
You can now close Native Access, restart MASCHINE and load the preset which was causing the issue. The preset should now load as expected.