Symptom
When trying to load a preset from the MASCHINE 2 Browser, you get the following error message mentioning a particular Native Instruments product:
Error: *NI Product* could not be loaded.
Cause
This means MASCHINE is unable to locate the NI plug-in associated with the preset. This can occur if:
- KONTAKT or REAKTOR have not yet been installed.
- Your NI plug-ins have been moved after the initial installation or deleted.
- Your NI plug-in location is missing in MASCHINE.
- Your harddrive has been renamed.
Solutions
To solve the issue, please follow the steps in this video:
Additionally, you can find all the troubleshooting steps below:
Install KONTAKT and REAKTOR
Many NI instruments require the KONTAKT or REAKTOR Players to function and thus, these must also be installed.
- Open Native Access.
- Click the Installed products tab and check if both, KONTAKT and REAKTOR are installed.
- If KONTAKT and / or REAKTOR are missing in the Installed products list, open the Not installed tab and install the missing products.
Using the Repair Function
If you notice there is a yellow REPAIR button, repair the installation as explained in this article or this video. After reinstalling or if you don't see a REPAIR button, proceed with the instructions below.
Plug-in Location
MASCHINE needs to be informed of where your plug-ins have been installed to. This is only an issue if you have chosen a custom location for your NI plug-ins, or if you have moved them after installation. The following will explain how to ensure MASCHINE is accessing the folder in which your plug-ins exist.
- Open Native Access' preferences.
- Take note of the VST 64 location:
- In the above example, we have chosen the custom location C:/VSTPlugins.
- Next, open MASCHINE standalone and navigate to the Preferences.
- Under Plug-ins > Locations, the VST 64 location from Native Access must be added to the list. To do this, click the Add button:
- Browse to the location of your 64-bit VST folder and click OK to confirm.
- Your plug-in folder has been added to the list. Click the Rescan button so that MASCHINE can add the new plug-ins:
You should now be able to load your plug-ins in MASCHINE.
Rescanning your MASCHINE Plug-in Database
If the above steps have not resolved the issue, you will need to reset the MASCHINE database. To do this, follow these steps:
- Close MASCHINE and press Win + R on your keyboard to open the Run dialog.
- Type in %localappdata% and click OK.
This will open the Appdata > Local folder. - Navigate to the Native Instruments folder and delete the Maschine 2 folder you find here.
- Now restart MASCHINE 2. It will take some moments to reinitialize it's database.
- If you have any custom VST folders, you would need to add these again to MASCHINE 2 under: Preferences > Plug-ins > Locations.
You should now be able to load your plug-ins in MASCHINE.