Symptom
When trying to load a preset from the MASCHINE 2 Browser, you get the following error message mentioning a particular Native Instruments product:
Error: *NI Product* could not be loaded.
Cause
When loading a preset from the Instrument section of the MASCHINE Browser, you actually load a plug-in (eg. FM8, MASSIVE, REAKTOR, etc.) which generates the sound of the preset. Additionally, many Presets from the Instrument section of the Browser belong to KONTAKT Libraries or REAKTOR Ensembles.
The above error message indicates that the VST plug-in of the NI product or of KONTAKT/REAKTOR is not found in its original installation path.
Solution
- Open Native Access.
- Under Installed products, scroll down to the product mentioned in the error message.
- Important: If you notice there is a yellow REPAIR button, repair the installation as explained in this article or this video. After reinstalling or if you see no REPAIR button, proceed with the instructions below.
- Click on the product's name to show the information window.
- Write down the installation path of the VST files.
- Close Native Access.
- Open the MASCHINE standalone application.
- Open the Preferences and go to Plug-ins > Locations.
- Check if the path you noted in Native Access is listed here. If it is, click Rescan. If it is not, click the Add button, navigate to the path listed in Native Access as VST location and select it. Once it is listed in the Plug-ins Locations Preferences, click Rescan.
You can now restart MASCHINE and load the preset which was causing the issue. The preset should now load as expected.