Symptom
When attempting to add a KONTAKT Library in Native Access, an error message appears stating that the path is invalid.
Cause
This can happen if the wrong folder is selected while adding a library through Native Access. Other causes are also covered in the solutions below.
Solutions
Click to expand the section below for instructions based on your version of Native Access.
Native Access 2
Selecting the Correct Library Folder
- Click the folder tab and browse for the specific KONTAKT Library folder.
- Choose the library folder containing the .nicnt file. This folder must contain the .nicnt file!
In this example, the Playbox Library folder will be selected.
Note: If adding a third-party library for KONTAKT, make sure to download and unzip the library according to the third-party manufacturer's instructions.
If the .nicnt file could not be located, follow the steps below to reinstall the library.
Reinstalling the Library
Follow these steps to use Native Access to reinstall the library.
Note: You can verify the library's install location in Native Access Preferences > File Management > Content Location. This can be changed if needed.
- Go to Library > All in Native Access and scroll to the library listing. Use the search bar along the top if needed.
- Click the Install tab next to the product title to start downloading the library.
If this issue is still not resolved, see the Additional Solutions chapter below.
Native Access 1
Selecting the Correct Library Folder
- Click the BROWSE tab and locate the specific KONTAKT Library folder.
- Choose the library folder containing the .nicnt file. This folder must contain the .nicnt file!
In this example, the Playbox Library folder will be selected.
Note: If adding a third-party library for KONTAKT, make sure to download and unzip the library according to the third-party manufacturer's instructions.
If the .nicnt file could not be located, follow the steps below to reinstall the library.
Reinstalling the Library
Follow these steps to use Native Access to reinstall the library.
Note: You can verify the library's install location in Native Access Preferences > File locations > Content location. See this article to learn how to change the install location if needed.
- Click the Not Installed tab in Native Access and scroll to the library listing. Use the search bar along the top if needed.
- Click the INSTALL tab next to the product title to start downloading the library.
If this issue is still not resolved, see the Additional Solutions chapter below.
Additional Solutions
Disabling Security Applications
In some rare cases, certain security software (e.g. BitDefender, Malwarebytes, MacCleaner, etc.) could cause issues with adding a library. Temporarily disable or uninstall any additional security apps you may have, then try relocating the KONTAKT library.
Enabling Full Disk Access (macOS only)
It may be necessary to enable macOS Full Disk Access to Native Access. To learn more about Full Disk Access click here.
- Open your Mac System Preferences and click Security & Privacy.
- Under Privacy, choose Full Disk Access from the sidebar.
- Click the lock icon in the bottom left and enter your macOS password.
- Scroll through the list of apps to locate Native Access.
Note: If Native Access is not listed, click the + icon to add it. The Native Access default location is: Macintosh HD > Applications > Native Access.
- Tick the box next to the Native Access icon.
- Click the lock icon again and close the System Preferences.
- Relaunch Native Access and try relocating the library again.
Using the Correct Hard Drive Format
Hard drives formatted as "case sensitive" are not compatible with NI products. The supported formats are listed below.
- Windows: NTFS
- macOS: Mac OS Extended (Journaled) for macOS 10.12 and earlier, and APFS (Apple File System) for macOS 10.13 and later.