Symptom
When you attempt to relocate a KONTAKT Library from the Not Installed tab in Native Access (Light version), you receive the following error:
The library path is invalid
A similar error occurs in Native Access (Dark version) when trying to Locate the library:
That path is invalid
Cause
The primary cause of this error is selecting the incorrect folder in Native Access, but other potential causes are also covered in the solutions below.
Solutions
Click the version of Native Access you are using below to reveal the appropriate steps:
Native Access (Light version)
Selecting the Correct Library Folder
In the examples above, we are trying to select the 40s Very Own – Drums library in the chosen location /Volumes/Music/Libraries. However, this location does not contain the library file (.nicnt) needed for Native Access to detect it.
To relocate the correct folder containing the .nicnt file, follow the steps below:
- In Native Access, hover your mouse to the left of the INSTALL button until the magnifying glass appears, then click it.
- Navigate to the specific folder of the affected KONTAKT library.
Important: Make sure that you choose the folder containing the .nicnt file of the library as shown in the example above.
If this process has not resolved your issue, proceed to the additional solutions below.
Redownloading the Library
If you are unable to find the .nicnt file on your computer or external hard drive, we recommend redownloading the library.
In order to do so, follow the steps below:
- First, in Native Access, navigate to the preferences as shown below:
- Click the BROWSE button next to the Content Location field and select the folder you want to install your libraries in. Click the SAVE button after you have made your choice.
- Click the INSTALL button next to the library to begin the installation process.
- Once the library has been reinstalled, the product should show FULL VERSION instead of the INSTALL button you previously clicked.
Regarding Third-Party Libraries
If you want to add a third-party KONTAKT Library, ensure that the library is downloaded and unzipped as per the instructions from the manufacturer of that library. This may differ depending on the manufacturer as some use their own download manager to download and unzip the library files in a given location, while others will provide instructions on how to do this manually.
If the issue persists after going through the steps above, continue to the Additional Solutions section below.
Native Access (Dark version)
Selecting the Correct Library Folder
In the examples above, we are trying to select the 40s Very Own – Drums library in the chosen location /Volumes/Music/Libraries. However, this location does not contain the library file (.nicnt) needed for Native Access to detect it.
To relocate the correct folder containing the .nicnt file, follow the steps below:
- In Native Access, click the ... button next to the affected product, then select Locate.
Note: If the REPAIR button is available, you can also click it and then click the RELOCATE button to find your library.
- Navigate to the specific folder of the affected KONTAKT library.
Important: Make sure that you choose the folder containing the .nicnt file of the library as shown in the example above.
If this process has not resolved your issue, proceed to the additional solutions below.
Redownloading the Library
If you are unable to find the .nicnt file on your computer or external hard drive, we recommend redownloading the library.
In order to do so, follow the steps below:
- First, in Native Access, click the Preferences button at the bottom left corner of the Native Access window, as shown below:
- Click the BROWSE button next to the Content Location field and select the folder you want to install your libraries in. Click the x button at the top right of the window after you have made your choice.
- Click the INSTALL button next to the library to begin the installation process.
- Once the library has been reinstalled, the product should show FULL VERSION instead of the previously visible INSTALL button.
Regarding Third-Party Libraries
If you want to add a third-party KONTAKT Library, ensure that the library is downloaded and unzipped as per the instructions from the manufacturer of that library. This may differ depending on the manufacturer as some use their own download manager to download and unzip the library files in a given location, while others will provide instructions on how to do this manually.
If the issue persists after going through the steps above, continue to the Additional Solutions section below.
Additional Solutions
Hard Drive Format
Hard drives formatted as "Case-Sensitive" are not compatible with our products.
The supported formats are NTFS for Windows and Extended (Journaled) for macOS 10.12 and earlier or Apple File System (APFS) for macOS 10.13 and later.
Ensure that the hard drive containing your libraries is formatted accordingly.
Security Software is Blocking Installation
In some rare cases, certain security software (such as BitDefender, MalwareBytes, MacCleaner, etc.) could cause issues with adding the libraries. Temporarily disabling or uninstalling such additional security software may solve the issue you are experiencing.
Enabling Full Disk Access (macOS only)
It may be necessary to grant Full Disk Access to certain Native Instruments apps in order for them to work correctly. More information on Full Disk Access can be found on the Apple website.
- Open your Mac's System Preferences and click Security & Privacy.
- Under the Privacy tab, choose Full Disk Access from the sidebar.
- Click the lock icon in the bottom left of the window and enter your macOS password.
- Ensure that your desired NI app appears in the list. In our example, we want to grant Native Access full disk access.
If it does not appear in this list, click the + icon and add the location of the NI app. In our example, we are adding Native Access from Macintosh HD > Applications > Native Access. - Once completed, click the lock icon again.