Symptom
When loading a project in MASCHINE 2, you receive the following error message mentioning a particular Native Instruments product:
Missing Plug-ins. The following Plug-ins could not be loaded:
Cause
This error message indicates that the plug-in required to load the preset is not found in the expected folder location. The plug-in has either been moved or deleted after installation.
Note: We strongly recommend not to move your NI plug-ins after installation.
Solutions
Click to expand the sections below to be guided through the recommended solutions.
macOS
Checking for the VST Plug-In File
KOMPLETE sounds in the MASCHINE 2 Browser require the VST and / or VST3 plug-in formats. If the VST or VST3 version of your NI plug-in is not installed or has been removed, this error message can appear.
To check for the VST plug-in, go to the following location of your computer:
Macintosh HD > Library > Audio > Plug-Ins > VST (folder) / VST3 (folder)
Verify that the NI VST files (.vst / .vst3) are present in their respective VST and VST3 folders.
Note: Please see this article for a list of NI products available in VST3 format.
If the VST versions are not found at the above locations, please proceed to the next chapter below.
Reinstalling the Affected Product
- Quit your DAW and all opened music software.
- Open Native Access and go to the Installed products tab.
- Scroll to the NI software missing the VST file, and hover your mouse over FULL VERSION (or PLAYER).
- Click REINSTALL when it appears, to begin the reinstallation process.
Note: This applies only to NI software plug-ins. You do not need to reinstall any sample libraries. See this article for a list of NI libraries and their associated plug-ins.
- Once the reinstallation is finished, relaunch the MASCHINE 2 software and check the Browser to load your presets.
If you still receive the same error message, please proceed to the next chapter below.
Enabling Full Disk Access
It may be necessary to grant Full Disk Access to certain Native Instruments apps in order for them to work correctly. More information on Full Disk Access can be found on the Apple website.
- Open the Mac System Preferences and click Security & Privacy.
- Under the Privacy tab, choose Full Disk Access from the sidebar.
- Click to open the lock icon at the bottom left of the window and enter your macOS password.
- Ensure that your NI product appears in the list. In this example, we allow Full Disk Access to KONTAKT and MASCHINE 2.
Note: If your NI Sofware is not listed, click the Plus (+) icon to add the software from this location of your computer: Macintosh HD > Applications > Native Instruments > *Product Name Folder*
- Once completed, click the lock icon to close it.
- Relaunch the MASCHINE 2 software and check the Browser to load your presets.
If you still receive the same error message, please proceed to the next chapter below.
Reset the MASCHINE 2 Database and Favorites
If the issue persists after going through the steps above, we recommend resetting the MASCHINE 2 database.
- Before proceeding with the steps below, please ensure that MASCHINE 2 and all other music applications are not running.
- Navigate to the folder containing your MASCHINE 2 database files:
Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments > Maschine 2
Note: The User Library folder is hidden. Please see this article for directions to access this folder.
- Delete the "Maschine 2" folder by right-clicking it and choosing Move to Trash.
- Delete the Favorites database file that is used by MASCHINE 2.
Note: Before proceeding, we recommend that you save a backup copy of the Favorites file before deleting it.
In the same User Library folder (above), go to:
Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments > Shared - Delete the file named favorites.db3 that you find in Shared.
- Relaunch the MASCHINE 2 software and wait for the database to rebuild. It may take some time for all content to re-appear in the browser.
- Once finished, check the MASCHINE 2 Browser to load your presets.
After following these troubleshooting steps, you should now be able to load your presets from within the MASCHINE 2 Browser.
Windows
Reinstalling the Affected Product
Follow these steps to ensure that your NI VST plug-ins are properly installed.
- Open Native Access.
- Go to Preferences to check the VST 64 and VST 32 file paths. In this example, the default locations are used.
VST 64:
C: > Program Files > Native Instruments > VSTPlugins 64 bit
VST 32:
C: > Program Files > Native Instruments > VSTPlugins 32 bit
Note: We generally recommend using the default paths and to keep the plug-in files there. However, you can set custom locations if needed. Please see this article for more details.
- Go to the Installed Products tab and scroll to the NI software missing the VST file.
- Hover your mouse over FULL VERSION (or PLAYER)
Note: If the plug-in from your error message is not found here, go to the Not Installed section of Native Access and install it from there.
- Click REINSTALL (or REPAIR) when it appears, to begin the reinstallation process.
Note: This applies only to NI software plug-ins. You do not need to reinstall any sample libraries. See this article for a list of NI Libraries and their associated plug-ins.
- Once reinstallation is finished, relaunch the MASCHINE 2 software and check the Browser to load your project or presets.
If you still receive the same error message, please proceed to the next chapter below.
Adding the VST Filepaths to MASCHINE 2 Preferences
Follow these steps to ensure that MASCHINE 2 is scanning the correct plug-ins folder.
- Launch Native Access and go to the Installed Products tab. Scroll down to the NI product mentioned in the error message.
- Click on the product's name to show the product information window.
- Write down the installation path of the VST files.
- Open the MASCHINE 2 standalone application.
- Open the Preferences and go to Plug-ins > Locations and check for the VST path you noted in step #3 (above).
- If the correct path is listed here, click Rescan.
- If the path is not listed here, click Add and navigate to the VSTPlugins 64 Bit location from Native Access. - Once added, click Rescan.
- Relaunch the MASCHINE 2 software and check the Browser to load your presets.
If you still receive the same error message, please proceed to the next chapter below.
Reset the MASCHINE 2 Database and Favorites
If the issue persists after going through the steps above, we recommend resetting the MASCHINE 2 database.
- Before proceeding with the steps below, please ensure that MASCHINE 2 and all other music applications are not running.
- Click the Windows Start button on the bottom left of your screen, type %localappdata% into the search bar, and press Enter. This will open the following folder location on your computer:
C: > Users > *Your User Name* > AppData > Local - From this location (Local), go to: Native Instruments > Maschine 2
- Delete the folder named Maschine 2 that you find here.
- Delete the Favorites database file that is used by MASCHINE 2.
Note: Before proceeding, we recommend that you save a backup copy of the Favorites file before deleting it.
In the same relative location (C: > Users > *Your User Name* > AppData > Local), go to: Native Instruments > Shared - Delete the file named favorites.db3 that you find in Shared.
- Relaunch the MASCHINE 2 software and allow the database to rebuild. It may take some time for all content to re-appear in the browser.
- Once finished, check the MASCHINE 2 Browser to load your presets.
After following these troubleshooting steps, you should now be able to load your presets from within the MASCHINE 2 Browser.