Symptom
When attempting to install a product from Native Access, you receive the following error:
Downloading (*Product*) failed: could not create new file or truncate existing file
Cause
This error is caused by setting the file locations to incompatible folders in Native Access preferences.
Solution
The following points must be observed when choosing custom file locations:
- Each file location must have a dedicated folder.
- Virtual or cloud drives cannot be chosen as a file location.
- The root drive cannot be chosen as a location.
Example 1
In the screenshot below, the user has set their external harddisk as the Download location. While this is fine to do, a dedicated folder must be chosen on that harddisk. The root disk location cannot be chosen. The correct location in this case should be /Volumes/Sandisk 480/Downloads. The other locations in this example are set correctly.
Example 2
Here, the user has set their Download location to their plug-ins folder. This is also incorrect. It must be set to a dedicated downloads folder (for example, /User/*user name*/downloads).
Additionally, the Application location and Content location are also set to the same folder. They must have dedicated folders. The default locations would be /Applications/Native Instruments and /Users/Shared.