Symptom
When starting Native Access, the self update is stuck at 0% and a message says:
Searching for the latest update:
Cause
This issue can be caused by individual Windows settings or your security software.
Solutions
Please try these 5 solutions one after the other and start Native Access inbetween to verify if the issue is resolved:
1. Start Native Access as administrator, by right-clicking and choosing Run as administator.
2. Open the Windows Settings > Privacy > Background Apps and activate the option Let apps run in the background:
3. Click the Windows Start button, type credential and hit 'enter'. This opens the Windows Credential Manager with the two tabs Web Credentials and Windows Credentials:
Check the Generic Credentials on both tabs Web Credentials and Windows Credentials. If there are entries for Native Access, expand the entry by clicking the little arrow button on the right and click Remove. Repeat these steps until all Native Access entries have been removed.
4. Check the settings of your firewall / antivirus / security software and make sure to set up exceptions for Native Access. The following URLs have to be unblocked:
- api.cloud.native-instruments.de
- http://artifacts-cdn.native-instruments.com/
- https://s3-eu-west-1.amazonaws.com/
- api.native-intruments.com
5. Start Windows in 'Safe Mode with Networking':
- On the Windows login screen, hold the 'shift' key on your keyboard, click the power button and, while still holding the 'shift' key, select Restart:
- Select Troubleshoot:
- Select Advanced options:
- Click on See more recovery options:
- Press '5' on your keyboard to select Enable Safe Mode with Networking:
Your computer will now reboot and Native Access' self-update should work without issues.