Symptom
When attempting to install a product from Native Access, the following error message appears:
Installation Failed
Cause
This issue occurs when Native Access does not have the necessary permissions to complete the installation.
Solution:
- Open your Mac's System Preferences and click Security & Privacy.
- Under the Privacy tab, choose Full Disk Access from the side bar.
- Click the lock icon in the bottom left of the window (if available) and enter your Mac password.
- Ensure that Native Access & NTKDaemon appear in the list and are activated.
If they do not appear in this list, click the + icon and add the following apps:
- Macintosh HD > Applications > Native Access
- Macintosh HD > Library > Application Support > Native Instruments > NTK > NTKDaemon
If you are trying to install Komplete Kontrol or Maschine, please also add NIHardwareAgent from:
- Macintosh HD > Library > Application Support > Native Instruments > Hardware > NIHArdwareAgent - Once completed, click the lock icon again (if available).
Depending on which macOS you are using, the interface may vary. In doubt, please look up how to open Full Disk Access on your specific macOS. Newer versions look like this: - Restart your computer and start Native Access.
The installations should run correctly now.