Symptom
A Native Instruments software application crashes on startup.
Note: If Native Access is crashing or freezing when attempting to open it, please check this article. However, the information below can also be used to further troubleshoot Native Access startup issues.
Cause
This behavior can have different causes. These troubleshooting steps list the most common solutions to NI software startup crashes on macOS systems.
Solutions
1. Enable Full Disk Access
It may be necessary to grant Full Disk Access to your NI application in order for it to work correctly. More information on Full Disk Access can be found on the Apple website.
- Open your Mac's System Preferences and click Security & Privacy.
- Under the Privacy tab, choose Full Disk Access from the sidebar.
- Click the lock icon in the bottom left of the window and enter your macOS password.
- Ensure that your NI application appears in the list.
If it does not appear in this list, click the + icon and add the location of your NI app. In this example, we are adding Maschine 2 from:
Mac HD: Applications > Native Instruments > Maschine 2 > Maschine 2.app. - Once completed, click the lock icon again.
2. Reinitialize the Application Database
- Go to the following location:
Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments
Note: The User Library folder is hidden on macOS. See this article for instructions to access this hidden system location.
- Search through the Native Instruments folder at this location to find the folder of the NI product that is crashing.
- Delete only the folder for the NI product that is crashing.
Note: Deleting other NI product folders could result in unexpected behavior with other applications.
- Reopen your NI software to check that the issue has been resolved.
3. Delete the User Preference (PLIST) File
- Go to the following location of your computer:
Macintosh HD > Users > *Your User Name* > Library > Preferences
Note: The User Library is a hidden folder on macOS. See this article for instructions to access this hidden system location.
- Search through the Preferences folder at this location, to find the plist file for the NI product that is crashing. The plist file will be named in this format:
com.native-instruments.*PRODUCT NAME*.plist - Delete only the plist file for the NI product that is crashing.
Note: Deleting other plist files could result in unexpected behavior with other applications.
- Reopen your NI software to check that the issue has been resolved.
4. Remove and Reinstall the NI Software
If the solutions listed above do not solve the problem, please try to completely remove and reinstall the NI software that is crashing.
Note: Uninstalling/reinstalling will not affect your DAW projects or saved documents. Reinstalling to the same computer does not affect your allowed number of authorizations (see this article for more info).
- Please follow this article for detailed instructions to manually remove the NI software application that is crashing.
Note: In most cases, it is not necessary to uninstall a Kontakt or large sample library folder to fix common issues. You can safely keep your sample library folders in place.
- Once the NI software application has been removed, it can be reinstalled from the Available tab in Native Access.