Symptom
When trying to open Traktor Pro, the application does not start or crashes immediately.
Cause
The Traktor settings and / or the Track Collection files may be corrupt.
Solutions
Click on the below chapters to reveal the steps.
Check your Track Collection for corrupted audio files
In order to protect yourself from unexpected behavior caused by corrupt files in your Track Collection, it is necessary to scan and either repair or delete your corrupt files. The following article helps you with the process:
If the issue persists, please proceed:
Reimport a backup Track Collection
- Navigate to the following folder:
- macOS: Macintosh HD > Users > *your username* > Documents > Native Instruments > Traktor X.X.X
- Windows: C: > User > *Your Username* > Documents > Native Instruments > Traktor X.X.X
- Move the collection.nml file to your desktop.
- Start Traktor Pro – it should start up properly without crashing.
- Follow the steps in this article in order to re-import your collection from a recent backup.
Note: Since you imported a Track Collection backup, the tracks that you've recently added may be missing. We recommend adding the missing tracks one by one in order to determine if one (or more) of them are corrupted and causing Traktor to crash upon startup.
If the issue persists, please proceed:
Reimport a backup Traktor Settings file
- Navigate to the following folder:
- macOS: Macintosh HD > Users > *your username* > Documents > Native Instruments > Traktor X.X.X
- Windows: C: > User > *Your Username* > Documents > Native Instruments > Traktor X.X.X
- Move the Traktor Settings.tsi file to your desktop.
- Start TRAKTOR – it should start up properly without crashing.
- Follow the steps in this article in order to reimport your TRAKTOR settings from a recent backup.
Install all Windows Updates
If you are a Windows user, make sure all your Windows components are up to date. To do so, follow these steps:
- Click the Windows Start button, type in 'windows updates', and hit the enter key.
- Check for updates.
- Install all available updates.
- After all of the updates are installed, restart your computer.
- Repeat steps 1. to 4 until no more updates are available.