S4 mk3 controls require calibration [en-us]

Pinned Open

Comments

121 comments

  • Official comment
    Avatar
    Mark @ NI (Edited )

    Important Note: Please read this message thoroughly before you apply the steps. Any carelessness may result in additional mis-calibration!

    What will happen now?

    You will need to download and run (not install) a Traktor build which will be used only for the recalibration. Please do the following:

    Installation
    the user must do the following steps to recalibrate his unit:

    • make sure the official version Traktor Pro 3.2.1  is installed and authorized on the computer
    • download the Traktor Pro 3.2.1 build from the link below, unpack it and launch it via double-click
    • connect and power-on the S4MK3
    • in Traktor go to Preferences > S4MK3 > Calibration
    • Chose to either calibrate the upper FX units or the entire Mixer Section and follow the instructions



    Note: all knobs of a section must be calibrated.  Omitting individual knobs will result in mis-calibration of these individual knobs.

    The calibration data is stored in the S4MK3 so that after successful calibration, therefore please discard the special Traktor build and continue using the installed official version 3.2.1
    Resources:

    Mac
    Kontrol S4 Mk3 3.2.1 Calibration Beta - MAC
    Win
    Kontrol S4 Mk3 3.2.1 Calibration Beta - WIN

    Comment actions Permalink
  • Avatar
    Kevin Harman

    Hi Mark,

    I am running Windows 10, build 17134.376.  Please let me know soonest if this is a hardware issue so that I can return it to the store before too much time has passed since my purchase.  Thank you for investigating.

    0
    Comment actions Permalink
  • Avatar
    Kevin Harman

    I also just noticed that a few of the FX knobs at the top of the unit also are not centred with the software.  

    0
    Comment actions Permalink
  • Avatar
    Gordan Gulic (Edited )


    I have the same problem. I´m on Mac OS Sierra 10.12.6

    0
    Comment actions Permalink
  • Avatar
    N/A N/A

    I have the same issue with channel A, EQ Low (bass) control. At center, it's offset by -3db

    A calibration must become available. I've seen other other users with similar issues. NI please provide some feedback on this subject.

    0
    Comment actions Permalink
  • Avatar
    Mark @ NI

    Hi all, this issue is being worked on as we speak, and we are optimistic that we can provide a solution next week. Please stay tuned, I will update you as soon as possible! We regret the inconvenience and appreciate your patience. 

    0
    Comment actions Permalink
  • Avatar
    Kevin Harman

    Great news Mark, thank you for keeping us posted!

    0
    Comment actions Permalink
  • Avatar
    Mark @ NI (Edited )

    We have now sent out tools & instructions for recalibration.

    @users who received these: please provide feedback on whether you could successfully apply the steps.

    @users who have not yet reported the issue: please post here so we can send you these tools & instructions as well.

    Thank you!

    0
    Comment actions Permalink
  • Avatar
    Gordan Gulic

    Tools worked fine

    0
    Comment actions Permalink
  • Avatar
    Kevin Harman

    Hi Mark,

    The calibration tool worked perfectly!  Thank you and the NI team for providing this fix.

    0
    Comment actions Permalink
  • Avatar
    mainTAP

    I also need to recalibrate the HI EQ knob on channel A :(

    0
    Comment actions Permalink
  • Avatar
    gillster11

    Hello I got the new s4 also loving it just slight issue with the low on channel B its off center it sits at -3 when in centre is there a way to calibrate this please

    0
    Comment actions Permalink
  • Avatar
    Nacho Duarte (Edited )

    Hi! My english is not so good sorry... I have the problem in Deck B with EQ Hi, and master EQ doesn't move. The first days i sed them they were fine... Can you help me and send the tool you mentioned here?

    Thank you very much

    Nacho Duarte

    P.D i use mac OS Mojave!

    0
    Comment actions Permalink
  • Avatar
    Florian Müller

    I also need to recalibrate the EQ knop on channel D bass and the channel A medium please. :(

     

    0
    Comment actions Permalink
  • Avatar
    Elvis Lewis (Edited )

    Same Problem too channel a+b pitch off centre c filter off centre please  can i get the fix i have a gig friday..

    0
    Comment actions Permalink
  • Avatar
    Oliver Lange

    same Problem here. (channel B, mid Knob. Thanks for the recalibration fix.

    0
    Comment actions Permalink
  • Avatar
    Luccid

    Same problem with my S2 MKIII, EQ knobs need recalibrating.

    0
    Comment actions Permalink
  • Avatar
    Camille Marchetti

    Same problem need recalibration fix. Thx

    0
    Comment actions Permalink
  • Avatar
    N/A N/A

    Same problem but the B fader is 50% and A/B filters are down

    0
    Comment actions Permalink
  • Avatar
    Oliver Lange

    Thanks for the quick response via eMail. Unfortunatly the recalibration has not fixed anything (Tried it twice) The Knob is

    still 4% off center. Any further suggestions?

    System is High Sierra

    0
    Comment actions Permalink
  • Avatar
    dirk verver

    same problem here on my Mac. The filter of deck B is off -3%  And the jogwheels are randomly spinning around??

    0
    Comment actions Permalink
  • Avatar
    manuel bagnoli

    I have the same problem of calibration with S4 mk3 - windows 10- 64 bit

    0
    Comment actions Permalink
  • Avatar
    Vinsen

    I also need to calibrate, many knobs are off-centre! Where can I find the tool and where is the NI QC?

    0
    Comment actions Permalink
  • Avatar
    Elvis Lewis

    Thanks the tool fixed my problem...

    1
    Comment actions Permalink
  • Avatar
    Vincent Venero

    Hi NI, I need the calibration tool for S4 mk3 as well. Please send a link. Thxs

    0
    Comment actions Permalink
  • Avatar
    Callan Olsen

    Hi,

    I'm encountering various calibration issues too - running on Windows 10.

    Could I have access to the calibration tool too please?

    Thanks

    0
    Comment actions Permalink
  • Avatar
    dirk verver (Edited )

    I bring back my s4 mk3. I dont know Why Native Instruments is so slow with giving this tool whigh has worked by Some people. Iam very dissappointed with this. I think i go off with traktor and looking for other soft/hardware

    0
    Comment actions Permalink
  • Avatar
    dirk verver

    I had also problems with my S4MK3 I had Traktor pro upgraded from previous versions. And now to the latest tractor pro 3

    I turned my s4mk3 on and i did have the same problems as mentioned above. Native Instruments suggested that i have to delete my Traktor Settings.tsi (Traktor must not be running; Mac OS X: Macintosh HD > Users > *Your username* > Documents > Native Instruments > Traktor 3.0.1 (your current version)> "Traktor Settings.tsi"

     

    This has solved (for so far i can see now) my problems. I 'don't know if this could help for u?

     

    0
    Comment actions Permalink
  • Avatar
    Erin Beebe

    I am having the same problem with my S4 MK3 and Windows 10 Pro PC. The filter knob on the B deck sits at +4% in the software when it is physically at 0 on the hardware. I have wiped the tsi, tried running the hardware wizard, and even uninstalling/reinstalling. The software keeps going back to +4%.

    Please send me the calibration tool/instructions.

    0
    Comment actions Permalink
  • Avatar
    Jamie Patmore

    I need to recalibrate also - I'm using a mac.  Could you send me the calibration tool fix mentioned in this thread please

    0
    Comment actions Permalink

Post is closed for comments.