Massive X - Sustain Pedal bug! [en-us]

Answered

Comments

28 comments

  • Official comment
    Avatar
    Massive X Team

    Chris filed a bug for this, we are investigating.  Give us a little time.

    Comment actions Permalink
  • Avatar
    Tom Phillips

    Just hazarding a guess here but you likely need to reverse the polarity of your sustain pedal; some pedals have a switch for that...in other cases you might have to dig into the global parameters of the instrument. Haven't installed Massive X yet but in the meantime, look into this. 

    -1
    Comment actions Permalink
  • Avatar
    EvilDragon

    Yeah I cannot confirm this behavior over here.

    -1
    Comment actions Permalink
  • Avatar
    Chris @ NI

    Hello,

    I am not able to reproduce this either. What is the sustain pedal that you are using? As Tom Phillips already suggested, if it does have a polarity switch, try switching that to see if it makes any difference.

    -1
    Comment actions Permalink
  • Avatar
    Nocturne (Edited )

    Issue has nothing to do with polarity of the sustain pedal.

    Issue occurs only with this plugin.

     

    Try loading patch "Bass">"Archangel" for example.

                                "Best of">"Alpha ape"

    1.Pres any key and hold

    2.Pres a sustain pedal >>let go

    3.It kills the sample

     

    *not all patches are affected

    *started browsing from "Best of" >> majority was affected.

    2
    Comment actions Permalink
  • Avatar
    EvilDragon

    Doesn't happen on those patches over here at all.

    -1
    Comment actions Permalink
  • Avatar
    Nocturne (Edited )

    I am up to date with every software piece - Massive X is hosted inside Maschine.

    There is nothing unique about my setup.

     

    Sustain pedal behaves normally with any other plugin. 

     

    *its important to not only press but also let go sustain pedal.

    *classically trained piano player - such sustain pedal behavior throws of any live performance.

    It wont affect people that prefer to draw notes.

     

     

    1
    Comment actions Permalink
  • Avatar
    EvilDragon (Edited )

    I'm also a classically trained piano player, I know how to use a sustain pedal. It works fine over here with all the presets you've mentioned. I've tried a bunch of other presets and it still worked perfectly.

    -1
    Comment actions Permalink
  • Avatar
    Nocturne (Edited )

    Chris @ NI

    I did more testing + reinstalled Massive X.

    *Machine has clean project just single plugin instance.

    *KK88 MK1 + generic sustain pedal.

     

    Issue persists but i noticed its intermittent with certain patches - still have not idea what is triggering this behavior.

     

    I picked couple more patches that have short release where i can consistently re-create the issue. 

     

    Key press >> Sustain pedal press >> Sustain pedal release >> audio is interrupted (i still haven't let go the note from the start.)

    Effect is the same as you would let go the note key,

     

    It probably would be easier to demonstrate it with a video but this is what i work with for now.

    *this is only plugin that i ever had issue with regarding sustain - i use allot of Kontakt, Serum mainly + others less.

     

    "Best Of" category:

    *Oxygen Mask

    *On Fire

    *Kali

    *Devine Acid 

     

    *Iron Throne - this particular one is weird >> only 1st sustain "pump" interrupts(full motion on>off) the note but following motions no longer affect it.

    That means - i can re-create the issue right after patch i loaded or re-loaded again.

    *Fruit Walk - same as above

    *Destroyer - same as above

    *April Dawn- same

     

    Massive was just released so its not a big deal for me - i can always use Serum for now.

    We will see if there are others that experienced this...

     

    I already swapped midi keyboard + sustain pedal - same there.

    Only thing that is left for me is try different DAW host and different computer.

    *i will get my laptop back next week to give it a try.

     

    Take Care!

    1
    Comment actions Permalink
  • Avatar
    Chris @ NI

    Thanks for providing more information. I was able to replicate your findings with a couple of the presets, but not all of them. I'll file this with the development team to investigate further.

    -1
    Comment actions Permalink
  • Avatar
    Nocturne

    Thanks Chris! - this issue is just weird,

    1
    Comment actions Permalink
  • Avatar
    XTC

    Any news? Problem is still there with full version of Massive X.

    0
    Comment actions Permalink
  • Avatar
    Nocturne

    There was an update to address other issues but this one remains.

     

    For time being i stopped using Massive X.

     

    Synth sounds great but personally this issue is to much of a distraction when playing/recording live.

    If You are drawing/programming the notes You should not be affected but issue at hand.

     

    *i also wish interface would be less like Reactor blocks.

    I would love to see massive interface to be more appealing to newcomers - just to give Serum run for its money.

    *more visual response to the way you manipulate the sound and more simplified interface.

     

    Will see what will happens in couple patches...

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Matthew Shallenberger

    I am also having this bug. I've noticed it on pretty much every preset I play. Right now I'm playing Deep Blue and here is how I experience the bug.

    Press a key (ex. C4).

    Press and hold the sustain pedal.

    Release the key; it sustains just fine.

    Press the same key again and hold this time.

    Now release the sustain pedal; the note ends even though the key is still being held.

    For me this leads to an effect that sounds like notes dropping out while I am playing. I thought maybe I was running out of polyphony, but I raised the limit to 64 and was still having trouble, so I began experimenting and discovered this problem.

    0
    Comment actions Permalink
  • Avatar
    Albin Andersson

    Any updates? Had to stop using Massive X for the same reason.

    0
    Comment actions Permalink
  • Avatar
    Keith Harrison

    Oof, I just designed half a huge live show on Massive X, and just discovered this issue as it's happening in some patches... I know it's the holidays, but this is a big uh oh... show opens in a couple of weeks. Please and thank you!

    0
    Comment actions Permalink
  • Avatar
    Keith Harrison (Edited )

    I know exactly when it happens. Fully reproducible in every patch, this is not patch-specific!

    • Play a note/chord.

    • Press the pedal.

    • Release the note/chord. The tone sustains while the pedals is pressed, as expected.

    • Play the same note/chord with the pedal pressed, and hold the keys down.

    • Release the pedal while holding the keys down. The tone releases, even though the keys are still pressed!

    This is a huge issue for playability, but I think it's simply a matter of finding where in the code a pedal release erroneously supersedes a repeated key press in terms of release data.

    0
    Comment actions Permalink
  • Avatar
    Chris @ NI

    Thanks for the specific steps, Keith. I have added them to the bug that I originally filed. There are a lot of people out of the office right now, but someone will have a look at this by the end of this week or early next week. I don't know when the next update is scheduled to be released, but hopefully, this will be included in it.

    0
    Comment actions Permalink
  • Avatar
    Keith Harrison

    Much appreciated! I’ll keep a lookout on this thread and in Access. 🙏

    0
    Comment actions Permalink
  • Avatar
    Matthew Shallenberger

    Any update on this? I see there is an update for Massive X in Native Access, but it says nothing about a bugfix for this problem.

    0
    Comment actions Permalink
  • Avatar
    XTC

    Hey NI, any news on this? As Massive X is a flagship product we hope this bug will be fixed now.

    2
    Comment actions Permalink
  • Avatar
    Matthew Shallenberger

    I see that patch 1.3 is out now. Does it fix the sustain pedal bug?

    0
    Comment actions Permalink
  • Avatar
    XTC

    I played some patches with V1.3 and it`s still the same.... Not fixed..........

    Hey NI! Still one year now after the first comment, we still need to have this issue solved. Please!!!

    3
    Comment actions Permalink
  • Avatar
    Matthew Shallenberger

    That is disappointing, to say the least. Come on NI. I love you guys; been a loyal customer for a few years now. But seriously.

    0
    Comment actions Permalink
  • Avatar
    Nocturne

    *almost 1 year later from opening this thread*

     

    Guys, I found how to fix this issue!

     

    All You have to do is to remove...sustain pedal OR remove MassiveX from Your session period. 

     

     

     

     

     

     

     

     

     

     

     

    1
    Comment actions Permalink
  • Avatar
    Matthew Shallenberger

    Just bumping this thread again to remind NI that they still haven't fixed this bug.

    2
    Comment actions Permalink
  • Avatar
    Albin Andersson

    I just stopped thinking it will ever be fixed and turn back to the old Massive whenever I need the sustain. A shame though, because I really like the Massive X.

    0
    Comment actions Permalink
  • Avatar
    XTC

    Hey NI team, please!! I`m so happy with the product and it´s so disappointing that i can`t enjoy playing my favourite sounds because of this bug. :((

    0
    Comment actions Permalink

Post is closed for comments.