Symptom
Your NI application crashes when you try to start it.
Cause
The application tries to load the driver for the on-board sound card of your computer, while different sample rates are set for the individual outputs of your sound card(s).
Solution
Make sure the sample rate is the same for all individual inputs and outputs of your sound cards:
- Go to the Windows Control Panel and open the Sound control panel.
- In the Playback section, click on one entry and choose Properties.
- In the Properties window, click the Advanced tab.
- Check the sample rate. In our example screenshot below, the sample rate is set to 44.100 Hz.
- Repeat this process for all entries in the Playback section and make sure to choose the same sample rate settings for all outputs.
- After finishing all the output entries, repeat the whole procedure for all input entries in the Recording section.
If the problem persists, follow these steps:
- Close all applications.
- Download and unzip the NI_regfile.zip file from the end of this article.
- Double-click the respective *productname*.reg file (e.g. Massive.reg).
- Confirm the import.
Proceed, depending on your audio interface:
If you are using an external audio interface:
- Start your NI application.
- Go to the Audio Settings and choose your interface's ASIO driver as Audio Device.
If you are using an on-board sound card:
- Download and install ASIO4ALL.
- Start your NI application.
- Open the Audio Settings and choose ASIO4ALL as your Audio Device.