Síntoma
Al instalar un producto de NI, el proceso de instalación falla y se muestra el siguiente mensaje de error:
NI InstallAware Plugin
FATAL ERROR: Can't write...
Causa
Los archivos del sistema de Windows relacionados a la instalación de un producto NI pueden estar dañados.
Soluciones
1. Reestablezca su carpeta temporal de instalación
- Navegue hacia la siguiente ubicación en su sistema:
C: > Usuarios > *nombre de usuario* > AppData > Local > TempNota: La carpeta temporal está oculta por defecto. Aprenda cómo mostrar archivos y carpetas ocultos en este artículo.
- Seleccione todos los archivos y carpetas en la carpeta "Temp", presionando Ctrl+A en su teclado.
- Elimine todos los elementos seleccionados haciendo clic con el botón derecho y seleccionando Eliminar en el menú contextual. Tenga en cuenta que algunos archivos y carpetas no se podrán eliminar.
- Reinstale el producto NI.
Si esta solución no da resultados, continúe como se explica a continuación.
2. Ejecute el Comprobador de archivos de sistema
Por favor, ejecute el Comprobador de archivos de sistema como se explica en este artículo de Microsoft.
Si esta solución no da resultados, continúe como se explica a continuación.
3. Limitación del tamaño de ruta de instalación
El problema también puede ocurrir si la ruta completa donde se crean los archivos de instalación excede la longitud límite definida en Windows. En este caso, asegúrese de abreviar la ruta que contiene sus productos de contenido:
- En Native Access, seleccione Preferences desde el ícono de usuario.
- En File locations, elija una carpeta diferente en su disco duro como ruta de contenidos (Content location). Asegúrese de que la ruta sea lo más corta posible. En este ejemplo, estamos seleccionando la carpeta D: / Tools / NI, ya que esta ruta es mucho más corta que la ruta establecida anteriormente 'D:> Tools> Music> Native Instruments> Content' (véase el mensaje de error arriba).
- Instale el producto nuevamente.
Si las soluciones anteriores no ayudan a resolver el problema, cree una nueva publicación en nuestra Comunidad de soporte.