Síntoma
Al instalar un producto NI, el proceso de instalación falla y Native Access muestra el siguiente mensaje de error:
Downloading (*Product*) failed: could not create new file or truncate existing file
Causa
Este error se debe a la configuración de las ubicaciones de los archivos en carpetas incompatibles en las preferencias de Native Access.
Solución
Deben observarse los siguientes puntos al elegir ubicaciones de archivos personalizadas:
- Cada ubicación de archivo debe tener una carpeta dedicada.
- Las unidades virtuales o cloud no se pueden elegir como una ubicación de archivo.
- La unidad raíz no se puede elegir como ubicación.
Ejemplo 1
En la captura de pantalla a continuación, el usuario ha configurado su disco duro externo como Download location (ubicación de descarga). Aunque esto está bien hacerlo, se debe elegir una carpeta dedicada en ese disco duro. La ubicación del disco raíz no puede ser elegida. La ubicación correcta en este caso debe ser /Volumes/Sandisk 480/Downloads. Las otras ubicaciones en este ejemplo están configuradas correctamente.
Ejemplo 2
Aquí, el usuario ha establecido su ubicación de descarga en su carpeta de plug-ins. Esto también es incorrecto. Debe configurarse en una carpeta de descargas dedicada (por ejemplo, /Usuario/* nombre de usuario */descargas).
Además, las carpetas Application location (ubicación de la aplicación) y Content location (ubicación del contenido) también se han configurado en la misma carpeta. Deben tener carpetas dedicadas. Las ubicaciones predeterminadas serían /Aplicaciones/Native Instruments y /Usuarios/Compartido.