Symptôme
Pendant l'installation d'un produit NI, le processus échoue et le message suivant s'affiche :
NI InstallAware Plugin
FATAL ERROR: Can't write...
Cause
Les fichiers systèmes de Windows relatifs à l'installation d'un produit NI peuvent être corrompus.
Solutions
1. Mettez votre dossier d'installation temporaire à zéro
- Naviguez jusqu'à l'emplacement suivant sur votre système :
C: > Utilisateurs > *votre nom d'utilisateur* > AppData > Local > TempNote: Le dossier temporaire est caché, par défaut. Apprenez comment afficher les fichiers et dossiers cachés dans cet article.
- Sélecctionnez tous les fichiers et dossiers dans le dossier Temp en appuyant sur Ctrl+A sur votre clavier.
- Effacez tous les objets sélectionnés en cliquant droit et en choisissant Supprimer dans le menu contextuel. Veuillez noter que certains fichiers ne pourront être effacés.
- Reinstallez le produit NI.If this solution does not help, continue as explained below.
2. Lancez l'outil vérificateur de fichiers (SFC/Scannow).
Veuillez lancer l'outil vérificateur de fichiers Windows sur votre système comme expliqué dans cet article Microsoft.
Si cette solution n'aide pas, continuez comme expliqué ci-dessous.
3. Limitation de la longueur d'un chemin d'accès d'un fichier
Le problème peut aussi se poser si le chemin d'accès total des fichiers créés dépasse la limite autorisée par Windows. Dans ce cas, assurez vous que le chemin d'accès qui contient vos produits soient réduits:
- Dans Native Access, sélectionnez Preferences du menu utilisateur.
- Sous File locations, choisissez un dossier différent sur votre disque dur comme destination de Content Location. Veuillez vous assurer que le chemin d'accès est le plus court possible. Dans cet exemple nous choisissons de le mettre sur le dossier D:/Tools/NI, puisque le chemin est beaucoup plus court que le chemin choisi auparavant D: > Tools > Music > Native Instruments > Content' (voir message ci dessus)
- Installez le produit à nouveau.