Symptôme
Lorsque vous tentez d'ajouter une bibliothèque KONTAKT dans Native Access, un message d'erreur apparaît, indiquant que le chemin d'accès n'est pas valide (That path is invalid).
Cause
Cela peut se produire si le mauvais dossier est sélectionné lors de l'ajout d'une bibliothèque via Native Access. D'autres causes sont également couvertes dans les solutions ci-dessous.
Solutions
Cliquez pour développer la section ci-dessous pour obtenir des instructions basées sur votre version de Native Access.
Native Access 1
Sélection du bon dossier de la bibliothèque
- Cliquez sur l'onglet dossier et recherchez le dossier spécifique de la bibliothèque KONTAKT.
- Choisissez le dossier de la bibliothèque contenant le fichier .nicnt. Dans cet exemple, le dossier Playbox Library sera sélectionné.
Remarque : si vous ajoutez une bibliothèque tierce pour KONTAKT, assurez-vous de télécharger et de décompresser la bibliothèque conformément aux instructions du fabricant tiers.
Si le fichier .nicnt n'a pu être localisé, suivez les étapes ci-dessous pour réinstaller la bibliothèque.
Réinstaller la bibliothèque
Suivez ces étapes pour utiliser Native Access afin de réinstaller la bibliothèque.
Remarque : vous pouvez vérifier l'emplacement d'installation de la bibliothèque dans Preferences > File Management > Content Location. Vous pouvez le modifier si nécessaire.
- Allez sur Library > All dans Native Access et faites défiler jusqu'à la bibliothèque. Utilisez la barre de recherche en haut de la page si nécessaire.
- Cliquez sur l'onglet Install à côté du titre du produit pour lancer le téléchargement de la bibliothèque.
Si ce problème n'est toujours pas résolu, consultez le chapitre Solutions supplémentaires ci-dessous.
Native Access 2
Sélection du bon dossier de la bibliothèque
- Cliquez sur l'onglet BROWSE et localisez le dossier spécifique de la bibliothèque KONTAKT.
- Choisissez le dossier de la bibliothèque contenant le fichier .nicnt. Dans cet exemple, le dossier Playbox Library sera sélectionné.
Remarque : si vous ajoutez une bibliothèque tierce pour KONTAKT, assurez-vous de télécharger et de décompresser la bibliothèque conformément aux instructions du fabricant tiers.
Si le fichier .nicnt n'a pu être localisé, suivez les étapes ci-dessous pour réinstaller la bibliothèque.
Réinstaller la bibliothèque
Suivez ces étapes pour utiliser Native Access afin de réinstaller la bibliothèque.
Remarque : vous pouvez vérifier l'emplacement d'installation de la bibliothèque dans Native Access Preferences > File locations > Content location. Consultez cet article pour savoir comment modifier l'emplacement d'installation si nécessaire.
- Cliquez sur l'onglet Not Installed dans Native Access et faites défiler jusqu'à la bibliothèque. Utilisez la barre de recherche en haut de la page si nécessaire.
- Cliquez sur l'onglet INSTALL à côté du titre du produit pour lancer le téléchargement de la bibliothèque.
Si ce problème n'est toujours pas résolu, consultez le chapitre Solutions supplémentaires ci-dessous.
Solutions supplémentaires
Désactiver les logiciels de sécurité
Dans certains cas rares, certains logiciels de sécurité (par exemple BitDefender, Malwarebytes, MacCleaner, etc.) peuvent causer des problèmes lors de l'ajout d'une bibliothèque. Désactivez ou désinstallez temporairement toute application de sécurité supplémentaire que vous pourriez avoir, puis essayez de déplacer la bibliothèque KONTAKT.
Activation de l'accès complet au disque (macOS uniquement)
Il peut être nécessaire d'activer macOS Accès complet au disque pour Native Access. Pour en savoir plus sur l'accès complet au disque, cliquez ici.
- Ouvrez les Préférences Système de votre Mac et cliquez sur Sécurité et confidentialité.
- Sous Confidentialité, choisissez Accès complet au disque dans la barre latérale.
- Cliquez sur l'icône de verrouillage en bas à gauche et saisissez votre mot de passe macOS.
- Faites défiler la liste des applications pour localiser Native Access.
Remarque : si Native Access ne figure pas dans la liste, cliquez sur l'icône + pour l'ajouter. L'emplacement par défaut de Native Access est : Macintosh HD > Applications > Native Access. - Cochez la case située à côté de l'icône Native Access.
- Cliquez à nouveau sur l'icône de verrouillage et fermez les Préférences Système.
- Relancez Native Access et essayez à nouveau de relocaliser la bibliothèque.
Utiliser le bon format de disque dur
Les disques durs formatés en " sensible à la casse " ne sont pas compatibles avec les produits NI. Les formats pris en charge sont énumérés ci-dessous.
- Windows: NTFS
- macOS : Mac OS Extended (Journaled) pour macOS 10.12 et antérieur, et APFS (Apple File System) pour macOS 10.13 et ultérieur.