Symptôme
Lorsque vous tentez de localiser une bibliothèque KONTAKT depuis l'onglet "Not Installed" dans Native Access (Version "claire"), vous recevez l'erreur suivante :
The library path is invalid
Une erreur similaire se produit dans Native Access (Version "sombre") lorsque vous essayez de localiser une bibliothèque :
That path is invalid
Cause
La principale cause de cette erreur est la sélection incorrecte du dossier contenant le fichier de bibliothèque dans Native Access, mais d'autres raisons potentielles sont également couvertes dans les solutions ci-dessous.
Solutions
Cliquez sur la version de Native Access que vous utilisez ci-dessous pour afficher les étapes appropriées :
Native Access (Version "claire")
Selection du dossier de la bibliothèque
Dans les exemples ci-dessus, nous essayons de sélectionner la bibliothèque 40s Very Own – Drums dans l'emplacement choisi /Volumes/Music/Libraries. Cependant, cet emplacement ne contient pas le fichier de bibliothèque (.nicnt) nécessaire à Native Access pour le détecter.
Pour déplacer le dossier correct contenant le fichier .nicnt, suivez les étapes ci-dessous :
- Dans Native Access, passez votre souris à gauche du bouton INSTALL jusqu'à ce que l'icône de loupe apparaisse, puis cliquez dessus.
- Naviguez vers le dossier spécifique de la bibliothèque KONTAKT concernée.
Important : assurez-vous de choisir le dossier contenant le fichier .nicnt de la bibliothèque comme indiqué dans l'exemple ci-dessus.
Si ce processus n'a pas résolu votre problème, passez aux solutions supplémentaires ci-dessous.
Retéléchargement de la bibliothèque
Si vous ne parvenez pas à trouver le fichier .nicnt sur votre ordinateur ou sur votre disque dur externe, nous vous recommandons de télécharger à nouveau la bibliothèque.
Pour ce faire, suivez les étapes ci-dessous :
- Tout d'abord, dans Native Access, naviguez vers les préférences :
- Cliquez sur le bouton BROWSE à côté du champ Content Location puis sélectionnez le dossier dans lequel vous voulez installer les bibliothèques. Cliquez sur le bouton SAVE après avoir fait votre choix.
- Cliquez sur le bouton INSTALL à côté de la bibliothèque afin de démarrer la procédure d'installation.
- Une fois la bibliothèque réinstallée, le produit doit afficher le texte FULL VERSION au lieu du bouton INSTALL sur lequel vous aviez cliqué précédemment.
À propos des bibliothèques tierces
Si vous souhaitez ajouter une bibliothèque KONTAKT tierce, assurez-vous que la bibliothèque est téléchargée et décompressée conformément aux instructions fournies par le fabricant de cette bibliothèque. Cela peut différer selon le fabricant car certains utilisent leur propre gestionnaire de téléchargement pour télécharger et décompresser les fichiers de la bibliothèque à un emplacement donné, tandis que d'autres fourniront des instructions pour ce faire manuellement.
Si le problème persiste après avoir suivi les étapes ci-dessus, passez à la section des solutions supplémentaires ci-dessous.
Native Access (Version "sombre")
Selection du dossier de la bibliothèque
Dans les exemples ci-dessus, nous essayons de sélectionner la bibliothèque 40s Very Own – Drums dans l'emplacement choisi /Volumes/Music/Libraries. Cependant, cet emplacement ne contient pas le fichier de bibliothèque (.nicnt) nécessaire à Native Access pour le détecter.
Pour déplacer le dossier correct contenant le fichier .nicnt, suivez les étapes ci-dessous :
- Dans Native Access, cliquez sur le bouton ... à côté du produit concerné, puis sélectionnez Locate.
Remarque : si le bouton REPAIR est disponible, vous pouvez également cliquer dessus, puis sur le bouton RELOCATE pour localiser votre bibliothèque.
- Naviguez vers le dossier spécifique de la bibliothèque KONTAKT concernée.
Important : assurez-vous de choisir le dossier contenant le fichier .nicnt de la bibliothèque comme indiqué dans l'exemple ci-dessus.
Si ce processus n'a pas résolu votre problème, passez aux solutions supplémentaires ci-dessous.
Retéléchargement de la bibliothèque
Si vous ne parvenez pas à trouver le fichier .nicnt sur votre ordinateur ou sur votre disque dur externe, nous vous recommandons de télécharger à nouveau la bibliothèque.
Pour ce faire, suivez les étapes ci-dessous :
- Tout d'abord, dans Native Access, cliquez sur le bouton des Préférences en bas à gauche de la fenêtre de Native Access :
- Cliquez sur le bouton BROWSE à côté du champ Content Location puis sélectionnez le dossier dans lequel vous voulez installer vos bibliothèques. Cliquez sur l'icône x en haut à droite de la fenêtre après avoir fait votre choix.
- Cliquez sur le bouton INSTALL à côté de la bibliothèque afin de démarrer la procédure d'installation.
- Une fois la bibliothèque réinstallée, le produit doit afficher le texte FULL VERSION au lieu du bouton INSTALL sur lequel vous aviez cliqué précédemment.
À propos des bibliothèques tierces
Si vous souhaitez ajouter une bibliothèque KONTAKT tierce, assurez-vous que la bibliothèque est téléchargée et décompressée conformément aux instructions fournies par le fabricant de cette bibliothèque. Cela peut différer selon le fabricant car certains utilisent leur propre gestionnaire de téléchargement pour télécharger et décompresser les fichiers de la bibliothèque à un emplacement donné, tandis que d'autres fourniront des instructions pour ce faire manuellement.
Si le problème persiste après avoir suivi les étapes ci-dessus, passez à la section des solutions supplémentaires ci-dessous.
Solutions supplémentaires
Format du disque dur
Les disques durs formatés "sensible à la casse" ne sont pas compatibles avec nos produits.
Les formats pris en charge sont NTFS pour Windows et Mac OS Étendu (journalisé) pour macOS 10.12 et versions antérieures ou Apple File System (APFS) pour macOS 10.13 et versions ultérieures.
Assurez-vous que le disque dur contenant vos bibliothèques est formaté en conséquence.
Un logiciel de sécurité bloque l'installation
Dans de rares cas, certains logiciels de sécurité (tels que BitDefender, MalwareBytes, MacCleaner, etc.) peuvent entraîner des problèmes lors de l'ajout des bibliothèques. La désactivation ou la désinstallation temporaire de ces logiciels de sécurité supplémentaires peut résoudre le problème que vous rencontrez.
Activation de l'accès complet au disque dur (macOS only)
Il peut être nécessaire d'accorder un accès complet au disque dur à certaines applications de Native Instruments pour qu'elles fonctionnent correctement. Plus d'informations sur l'activation de l'accès complet au disque dur sont disponibles sur le site Web d'Apple.
- Ouvre les préférences système de ton Mac puis clique sur l'onglet Securité et confidentialité.
- Dans l'onglet Confidentialité, clique sur Accès complet au disque depuis le menu latéral.
- Clique sur l'icône de cadenas en bas à gauche de la fenêtre puis tape ton mot de passe de macOS.
- Assure-toi que l'application de NI apparaît dans la liste. Dans notre exemple, nous voulons donner l'accès complet au disque à Native Access.
Si l'application n'apparaît pas dans la liste, clique sur l'icône + et rajoute l'application en question. Dans notre exemple, nous avons rajouté Native Access depuis l'emplacement suivant:
Macintosh HD > Applications > Native Access - Une fois l'ajout terminé, clique à nouveau sur le cadenas.