Symptôme
Lors de la mise à jour du firmware de votre appareil NI, vous pouvez être confronté à l'un des scénarios suivants :
- Votre appareil n'est pas reconnu par le programme de mise à jour du firmware (« Firmware Updater »).
- Le programme de mise à jour du firmware reconnaît l'appareil et détecte le firmware ancien, mais il quitte inopinément et l'appareil n'est plus reconnu par votre ordinateur.
- Le programme de mise à jour du firmware quitte inopinément, en affichant le message d'erreur suivant :
"An error occurred while updating your *NI Device* (error -2)"
Causes
Ce problème peut être causé par une ou plusieurs des raisons suivantes :
- La dernière mise à jour du pilote de votre appareil n'est pas installée.
- Un navigateur Web ou un service cloud est en cours d'exécution lors de la tentative de mise à jour du micrologiciel.
- Votre système d'exploitation doit être mis à jour (Windows 10 uniquement).
Solutions
- Assurez-vous que le dernier pilote pour votre appareil est installé. Vous trouverez tous les pilotes disponibles sur notre page des téléchargements.
- Avant de lancer Firmware Updater, assurez-vous que toutes les fenêtres du navigateur Web sont fermées et qu'aucun service cloud ne s'exécute en arrière-plan.
- Si vous êtes sur Windows 10, assurez-vous que la dernière mise à jour de Windows est installée. Vous trouverez cette options dans :
Paramètres > Mise à jour & sécurité > Windows Update > Rechercher des mises à jour. - Si les solutions précédentes ne fonctionnaient pas, essayez d'exécuter le programme de mise à jour du micrologiciel sur un compte invité de votre système d'exploitation ou, si disponible sur un autre ordinateur.