Symptôme
En essayant d'installer un produit avec Native Access, vous recevez le message d'erreur suivant:
Downloading (*Product*) failed: could not create new file or truncate existing file
Cause
Ce problème est provoqué par le choix de dossiers incompatibles comme emplacements de fichiers dans les préférences de Native Access
Solution
Il faut respecter les points suivants lors du choix d'emplacements de fichiers personnalisés:
- Chaque emplacement de fichier doit avoir un dossier dédié.
- Il n'est pas possible de choisir de disque virtuel ou dans le cloud comme emplacement de fichiers.
- Le dossier racine d'un disque ne peut pas être choisi comme emplacement de fichiers.
Exemple 1
Dans la capture d'écran ci-dessous, l'utilisateur a défini son disque dur externe comme emplacement de téléchargement (Download location). Cela est possible, toutefois il faut choisir un dossier dédié sur ce disque dur. Le dossier racine du disque ne peut pas être choisi comme emplacement. Un emplacement approprié serait par exemple /Volumes/Sandisk 480/Downloads. Les autres emplacements dans cet exemple sont définis correctement.
Exemple 2
Ici, l'utilisateur a défini son dossier de plug-ins comme emplacement de téléchargement. Cela est incorrect. Il doit être choisi dans un dossier dédié aux téléchargements, par exemple /Utilisateur/*nom de l'utilisateur*/téléchargements).
Il est aussi incorrect d'avoir choisi le même dossier comme emplacement des applications (Application location) et emplacement des contenus (Content location). Ils doivent, eux aussi, avoir des dossiers dédiés. Les emplacements par défaut sont /Applications/Native Instruments and /Utilisateurs/Partagé.