症状
Native Accessを起動すると、以下のメッセージが表示されます:
Can't connect to the internet. Please check your connection settings or disable your VPN.
原因
この問題は通常、以下のいずれかのコンポーネントがNative Accessのサーバーへの接続を妨げることによって発生します:
- VPN/プロキシ
- ネットワークセキュリティソフトウェア/設定
- ウイルス対策ソフトウェア
解決策
通常、上記のソフトウェアコンポーネントを無効にすると問題は解決します。
問題が解決しない場合は、問題の要因を特定するために、ホットスポットに一時的に接続してみてください:Native Instruments製品をオフラインコンピュータでアクティベートするためにWi-Fiホットスポットを設定する方法
続いてNative Accessを起動し、ダウンロードをお試しください。正常に開始した場合は、通信データを節約するためにキャンセルできます。
この状態でダウンロードが正常に開始された場合、問題の原因はネットワーク/インターネット設定のコンポーネントにあることは間違いありません。
詳細情報は以下となります:
1. サポート外のVPN ネットワークが使用されている
VPNクライアントをご使用の場合は、無効にした上でNative Accessを実行してください。
2. ウイルス対策ソフトがNative Accessをブロックしている
Native Accessの起動時に問題が発生する場合は、実行中のウイルス対策プログラムをすべて無効にしてみてください。
3. 接続ソースを変更する
ルーター自体の特定の設定がNative Accessをブロックしている可能性があるため、可能であれば別のルーターへの接続をお試しください。WIFIからイーサネット(有線)に切り替えたり、その逆を試すことも有効です。
ホットスポットの設定は、ルーターが問題の原因であるかどうかを判断するのにも役立ちます:
Native Instruments製品をオフラインコンピュータでアクティベートするためにWi-Fiホットスポットを設定する方法
4. 拡張子が「iso」または「aria」のファイルを削除する
- 全てのアプリケーションを終了します。
-
Download Locationに設定しているフォルダを開き、拡張子が「iso」または「aria」のファイルを削除します(下図参照)
- コンピュータを再起動します。
- Native Accessを起動して、再度インストールをお試しください。
5. ファイアウォールの設定で、ポート80と443を有効にする
ご使用ファイアウォールの設定で、ポート80と443が開いており、外部からの接続が許可されているかご確認ください。
6. DNSサーバーアドレスを変更する
DNSサーバーアドレスを、8.8.8.8(Google Public DNS)に変更してください。MacとWindowsの変更手順については、こちらの外部サイトをご参照ください。
さらなるトラブルシューティング
ご使用のオペレーティングシステムを選択してください。
Mac
1. ファイアウォールがNative Accessをブロックしている
Native Accessに製品をダウンロードするために必要な権限を与えるために、ファイアウォールを無効にしてみてください。
ファイアウォールを無効にするには、次の手順に従ってください:
- Appleメニュー> システム環境設定を開きます。
- セキュリティとプライバシーをクリックします。
- ファイアウォールタブをクリックします。
- 左下にある鍵をクリックしてロックを解除し、管理者のユーザ名とパスワードを入力します。
- ファイアウォールをオフにするをクリックします。
無効にした後、Native Accessから製品のインストールを再度お試しください。ファイアウォールを有効にする場合は、上記の手順を再度実行して、ファイアウォールをオンにするを選択してください。
サードパーティ製のファイアウォールアプリケーションも無効にする必要があります。
2. プロキシサーバーが使用されている
プロキシを無効にしてみてください。
- Appleメニュー> システム環境設定を開きます。
-
ネットワークをクリックします。
-
左側からご使用のネットワークサービスを選択し、詳細...ボタンをクリックします。
-
プロキシタブを開き、構成するプロトコルを選択ですべてのプロトコルのチェックを外します。
-
OKをクリックします。
無効にした後、Native Accessから製品のインストールを再度お試しください。インストール完了後にプロキシサーバーを再有効するには、上記の手順を再度実行して、構成するプロトコルを選択でプロトコルを有効にしてください。
3. iCloudプライベートリレーを無効にする(macOS 12 Montereyのみ)
macOS 12(Monterey)は、ネットワークへのより安全な接続を可能にする、いわゆるiCloudプライベートリレーサービス(ベータ版)を提供しています。NI製品をインストールする際は、このサービスを無効にすることをお勧めします:
- Macのシステム環境設定 > ネットワークを開きます。
- サイドバーでWi-FiまたはEthernet接続を選択します。
- iCloudプライベートリレーを無効にするには、IPアドレスのトラッキングを制限ボックスのチェックを外してください。
Windows
1. ファイアウォールがNative Accessをブロックしている
以下の手順に従って、Windows Defenderファイアウォールを無効にしてください:
- 画面左下にあるWindowsアイコンをクリックして「ファイアウォール」と入力し、Enterキーを押します。
- 検索結果からWindows Defenderファイアウォールをクリックします。
- 左側のメニューからWindows Defenderファイアウォールの有効化または無効化を選択します。
- 両方のネットワーク(プライベートとパブリック)で、Windows Defenderファイアウォールを無効にするを選択します。
無効にした後、Native Accessから製品のインストールを再度お試しください。インストール後、Windows Defenderファイアウォールを有効にすることをお勧めします。
サードパーティ製のファイアウォールアプリケーションも無効にする必要があります。
2. プロキシサーバーが使用されている
- 画面左下にあるWindowsアイコンをクリックして「プロキシ」と入力します。
- 検索結果からプロキシの設定を変更するをクリックします。
- 設定を自動的に検出するをオンに設定します。
- プロキシサーバーを使うをオフに設定します。
上記設定にした後、Native Accessから製品のインストールを再度お試しください。
3. コントロールされたフォルダーアクセス
場合によっては、Windowsのコントロールされたフォルダーアクセスを無効にする必要があります。
-
Windowsキー+「I」を押してWindows設定を開き、更新とセキュリティオプションを選択します:
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Windowsセキュリティ > Windows Defenderセキュリティセンターを開くを選択します。
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ウイルスと脅威の防止を選択し、ウイルスと脅威の保護の設定にある設定の管理を開きます。
-
コントロールされたフォルダーアクセスをオフに設定してください。
注意:信頼するアプリの許可リストにNative Accessを追加することもできます。この場合、コントロールされたフォルダーアクセスオプションを無効にする必要はありません。Microsoft社のこちらの記事では、これを行う方法についてご確認いただけます。
無効にした後、Native Accessから製品ダウンロードを再度お試しください。
4. Windows の Wi‑Fi 接続の問題を解決する
それでも同じ問題が発生する場合は、マイクロソフトのサポート記事の指示に従ってください: