症状
Komplete Kontrol S-シリーズキーボードの鍵盤を弾いても音が鳴らず、Komplete KontrolのPreferencesでMIDI装置として設定できない。
原因
この問題は以下の要因が考えられます:
- NIHardwareAgent / NIHostIntegrationAgentサービスが動作していない。
- キーボードのMIDIインプットポートがオフになっている。
- キーボードが接続されていない。
- Macのみ: HALフォルダ内のプラグインがキーボードの認識を妨げている。
- Windowsのみ: キーボードのドライバが正しくインストールされていない。
解決策
この問題を解決するには以下の手順に従ってください:
- 以下の手順で、NIHardwareAgentとNIHostIntegrationAgentが動作しているかご確認ください:
Mac
- Macのシステム環境設定からユーザとグループ > ログイン項目を開きます。
- 項目内のリストにNIHardwareAgent / NIHostIntegrationAgentがない場合、[+]アイコンをクリックして以下の場所を参照してください:
Macintosh HD > ライブラリ > Application Support > Native Instruments > Hardware - 項目内にないサービスを選択し、追加をクリックします:
注意:コンピュータのキーボードでSHIFTキーを押しながら複数の項目をクリックすることで、複数選択が可能です。
Windows
- Windowsタスクマネージャからサービスタブを開きます。
注意:サービスタブが表示されていない場合は、画面左下にある「詳細」をクリックして画面表示を拡大してください。
- リスト内のNIHostIntegrationAgentとNIHardwareServiceの状態が、実行中となっているかご確認ください:
- 実行中となっていない場合は項目を右クリックし、コンテクストメニューから開始を選択します:
- Macのシステム環境設定からユーザとグループ > ログイン項目を開きます。
- キーボードのMIDIインプットポートを有効にする:
- Komplete KontrolのPreferencesを開き、MIDIタブのInputを選択します。
- Mac: Inputが有効となっているかご確認ください。Inputにチェックが入っていない場合は、項目の右側にある四角をクリックしてInputを有効にしてください:
- Windows: Inputが有効となっているかご確認ください。Inputにチェックが入っていない場合は、項目の右側にある四角をクリックしてInputを有効にしてください:
- 製品に付属していた純正のUSBケーブルを使用して、コンピュータに直接接続してください。USBハブを使用しなければならない場合は、電源付きのハブをご使用ください。
- Macのみ: HALフォルダ内のプラグインがキーボードの認識を妨げているか確認する方法は、こちらの記事をご参照ください。
- Windowsのみ: キーボードのドライバが正しくインストールされているか確認する方法は、こちらの記事の第2章と第3章をご参照ください。