症状
Native Access(ライトバージョン)のNot InstalledタブからKONTAKTライブラリを配置しようとした際、以下のエラーが表示されます:
The library path is invalid
Native Access(ダークバージョン)でもライブラリをLocateしようとした際、同様のエラーが発生します:
That path is invalid
原因
このエラーの主な原因は、Native Accessで誤ったフォルダを選択していることですが、他の潜在的な原因も以下の解決策でカバーされています。
解決策
以下から使用しているNative Accessのバージョンをクリックして、適切な手順をご確認ください:
Native Access(ライトバージョン)
正しいLibraryフォルダを選択する
下図の例では、選択した場所 /Volumes/Music/Librariesにある40s Very Own – Drumsライブラリを選択しようとしていますが、この場所には、Native Accessがライブラリを検出するために必要なライブラリファイル(.nicnt)が含まれていません。
.nicntファイルを含む正しいフォルダを再配置するには、以下の手順に従ってください:
- Native AccessでINSTALLボタンの左側にマウスを置き、表示される虫眼鏡をクリックします。
- 該当のKONTAKTライブラリのフォルダに移動します。
重要事項:上図の例に示すように、ライブラリの.nicntファイルを含むフォルダを選択していることをご確認ください。
この処理で問題が解決しない場合は、以下の追加の解決策にお進みください。
ライブラリの再ダウンロード
コンピュータ上に.nicntファイルが見つからない場合は、ライブラリを再ダウンロードすることをお勧めします。
これを行うには以下の手順に従ってください:
- まず、Native AccessでPreferencesを開きます:以下に示すように設定に移動します。
- Content Locationの横にあるBROWSEボタンをクリックし、ライブラリをインストールしたいフォルダを選択した上でSAVEボタンをクリックします。
- ライブラリの横にあるINSTALLボタンをクリックして、インストール処理を開始します。
- ライブラリが再インストールされると、以前にクリックしたINSTALLボタンに代わり、FULL VERSIONと表示されます。
サードパーティ製ライブラリについて
サードパーティ製のKONTAKTライブラリを追加する場合は、音源メーカーの指示する手順に従って、ライブラリがダウンロードされ、解凍されていることをご確認ください。これは、独自のダウンロードツールを使用するものもあれば、手動で一連の操作を行う必要があるなど、音源メーカーによってダウンロード方法が異なるためです。
上記の手順を実行しても問題が解決しない場合は、以下の追加の解決策セクションにお進みください。
Native Access(ダークバージョン)
正しいLibraryフォルダを選択する
下図の例では、選択した場所 /Volumes/Music/Librariesにある40s Very Own – Drumsライブラリを選択しようとしていますが、この場所には、Native Accessがライブラリを検出するために必要なライブラリファイル(.nicnt)が含まれていません。
.nicntファイルを含む正しいフォルダを再配置するには、以下の手順に従ってください:
- Native Accessで該当製品の横にある...ボタンをクリックし、Locateを選択します。
注意:REPAIRボタンが表示されている場合は、それをクリックしてからRELOCATEボタンをクリックしてライブラリを検索することもできます。
- 該当のKONTAKTライブラリのフォルダに移動します。
重要事項:上図の例に示すように、ライブラリの.nicntファイルを含むフォルダを選択していることをご確認ください。
この処理で問題が解決しない場合は、以下の追加の解決策にお進みください。
ライブラリの再ダウンロード
コンピュータ上に.nicntファイルが見つからない場合は、ライブラリを再ダウンロードすることをお勧めします。
これを行うには以下の手順に従ってください:
- まず、Native Accessの画面左下にあるPreferencesボタンをクリックします:
- Content Locationの横にあるBROWSEボタンをクリックし、ライブラリをインストールしたいフォルダを選択した上でxボタンをクリックします。
- ライブラリの横にあるINSTALLボタンをクリックして、インストール処理を開始します。
- ライブラリが再インストールされると、以前にクリックしたINSTALLボタンに代わり、FULL VERSIONと表示されます。
サードパーティ製ライブラリについて
サードパーティ製のKONTAKTライブラリを追加する場合は、音源メーカーの指示する手順に従って、ライブラリがダウンロードされ、解凍されていることをご確認ください。これは、独自のダウンロードツールを使用するものもあれば、手動で一連の操作を行う必要があるなど、音源メーカーによってダウンロード方法が異なるためです。
上記の手順を実行しても問題が解決しない場合は、以下の追加の解決策セクションにお進みください。
追加の解決策
ハードドライブフォーマット
「大文字と小文字を区別する」フォーマットのハードドライブは、弊社製品と互換性がありません。
サポートされているフォーマットについて、Windowsの場合はNTFS、macOS 10.12以前の場合はmacOS拡張(ジャーナリング)、macOS10.13以降の場合はApple File System (APFS) となります。
ライブラリを格納しているハードドライブが適切なフォーマットであることをご確認ください。
セキュリティソフトウェアがインストールをブロックしている
稀に、特定のセキュリティソフトウェア(BitDefender、MalwareBytes、MacCleanerなど)がライブラリの追加で問題を引き起こす可能性があります。このような追加のセキュリティソフトウェアを一時的に無効にするかアンインストールすると、発生している問題が解決する場合があります。
フルディスクアクセスの有効化(macOSのみ)
特定のNative Instrumentsアプリを正しく動作させるために、フルディスクアクセスを許可する必要がある場合があります。フルディスクアクセスの詳細については、こちらのApple社ウェブサイトをご参照ください。
- Macのシステム環境設定を開き、セキュリティとプライバシーをクリックします。
- プライバシータブを開き、サイドバーからフルディスクアクセスを選択します。
- 画面左下にある鍵のアイコンをクリックして、macOSのパスワードを入力します。
- 目的のNIアプリがリストに表示されていることを確認します。この例では、Native Accessにフルディスクアクセスを許可します。
このリストにアプリが表示されない場合は、+アイコンをクリックして、NIアプリの場所を追加します。この例では、Macintosh HD > アプリケーション > Native AccessからNative Accessを追加しています。 - 完了後、鍵アイコンをもう一度クリックします。