症状
NIハードウェアデバイスのファームウェアをアップデートしようとした際、以下のいずれかの状況が発生する場合があります:
- ファームウェアアップデータがデバイスを認識しない
- ファームウェアアップデータはデバイスを認識して古いファームウェアを検出するが、アップデートを行おうとするとデバイスが認識されなくなり中止してしまう
- ファームウェアアップデートが以下のエラーメッセージで中止してしまう:
「An error occurred while updating your *NIデバイス* (error -2)」
原因
この問題は、次のうち1つ以上の原因で発生する可能性があります:
- ご使用デバイスの最新ドライバがインストールされていない
- ファームウェアアップデートを実行する際、ウェブブラウザやクラウドサービスが起動している
- オペレーティングシステムの更新が必要である (Windows 10のみ)
解決策
- ご使用デバイス用の最新ドライバがインストールされていることをご確認ください。利用可能なすべてのドライバは、弊社ダウンロードページでご確認いただけます。
- ファームウェアアップデータを起動する前に、すべてのウェブブラウザウィンドウが閉じられており、バックグラウンドでクラウドサービスが実行されていないことをご確認ください。
- Windows 10をご使用の場合は、最新のアップデートがインストールされていることをご確認ください。このオプションは以下の場所にあります:設定 > 更新とセキュリティ > Windows Update > 更新プログラムのチェック
- 上記の対策でも問題が改善されない場合は、コンピュータの別アカウントや、別のコンピュータでファームウェアアップデートをお試しください。