症状
Maschineでプロジェクトをロードする際、特定のNative Instruments製品に関する以下のエラーメッセージが表示されます:
Missing Plug-ins. The following Plug-ins could not be loaded:
原因
このエラーメッセージは、プリセットをロードするために必要なプラグインが見つからないことを示しています。該当プラグインが、インストール後に移動または削除された可能性が考えられます。
注意:インストール後にNIプラグインを移動されないようご注意ください。
解決策
以下のセクションをクリックして展開し、推奨される解決策をご確認ください。
macOS
VSTプラグインファイルの確認
MaschineブラウザのKompleteサウンドには、VSTまたはVST3プラグインが必要です。NIプラグインのVSTまたはVST3バージョンがインストールされていないか、削除されてしまった場合、このエラーメッセージが表示されることがあります。
VSTプラグインは、コンピュータの以下の場所でご確認いただけます:
Macintosh HD > ライブラリ > Audio > Plug-Ins > VST (フォルダ) / VST3 (フォルダ)
NI VSTファイル(.vst/.vst3)がVSTフォルダとVST3フォルダに存在することをご確認ください。
注意:VST3フォーマットで利用可能なNI製品のリストについては、こちらの記事をご参照ください。
上記の場所にVSTファイルが存在しない場合は、以下の次章にお進みください。
影響を受けている製品を再インストールする
- 全てのアプリケーションを終了します。
- Native Accessを起動し、Library > Installedタブを開きます。
-
VSTファイルがない製品までスクロールし、製品項目の右側にある3つのドットメニューからReinstallを選択します。
注意:オリジナルのNative Access(ライトバージョン)をご使用の場合は、こちらの記事をご参照ください。
- 完了後、Maschineを再起動し、ブラウザからプリセットのロードをお試しください。
それでも同じエラーメッセージが表示される場合は、次章にお進みください。
フルディスクアクセスの有効化
ソフトウェアを正常動作させるために、特定のNative Instrumentsアプリにフルディスクアクセスを許可することが必要となる場合があります。フルディスクアクセスの詳細については、Apple社ウェブサイトをご参照ください。
- Macのシステム環境設定からセキュリティとプライバシーを開きます。
- プライバシータブを開き、サイドバーからフルディスクアクセスを選択します。
- 画面左下にある鍵アイコンをクリックし、macOSのパスワードを入力します。
-
NI製品がリストに表示されていることをご確認ください。この例では、KONTAKTとMASCHINE 2にフルディスクアクセスを許可しています。
注意:NIソフトウェアがリストにない場合は、プラス(+)アイコンをクリックして、コンピュータの以下の場所からソフトウェアを追加してください:Macintosh HD > アプリケーション > Native Instruments > *製品名フォルダ*
- 完了後、鍵アイコンをクリックして閉じます。
- MASCHINE 2ソフトウェアを再起動し、ブラウザからプリセットのロードをご確認ください。
それでも同じエラーメッセージが表示される場合は、次章にお進みください。
MaschineデータベースとFavoritesをリセットする
上記手順を実行しても問題改善されない場合は、Maschineのデータベースをリセットすることをお勧めします。
- 以下の手順を実行する前に、Maschineおよび他のすべてのアプリケーションが起動していないことをご確認ください。
-
Maschineデータベースファイルを含む以下のフォルダを参照します:
Macintosh HD > ユーザ > *ユーザ名* > ライブラリ > Application Support > Native Instruments
注意:ユーザライブラリフォルダは非表示になっています。このフォルダにアクセスする方法については、こちらの記事をご参照ください。
-
「Maschine 2 / 3」フォルダを右クリックして「ゴミ箱に入れる」を選択して削除します。
- 続いてMaschineで使用されているFavoritesデータベースファイルを削除します。
注意:削除する前に、Favoritesファイルのバックアップコピーを保存することをお勧めします。
上記と同じユーザライブラリフォルダで、以下の場所を参照します:
Macintosh HD > ユーザ > *ユーザ名* > ライブラリ > Application Support > Native Instruments > Shared
- Sharedにあるfavorites.db3という名前のファイルを削除します。
-
MASCHINEソフトウェアを再起動し、データベースが再構築されるまでお待ちください。すべてのコンテンツがブラウザに再表示されるまでに時間がかかる場合があります。
- 完了後、MASCHINEのブラウザからプリセットのロードをお試しください。
これらのトラブルシューティングを実行すると、MASCHINEブラウザ内からプリセットをロードできるようになるはずです。
Windows
影響を受けている製品を再インストールする
以下の手順に従って、NI VSTプラグインが正しくインストールされているかご確認ください。
- 全てのアプリケーションを終了します。
- Native Accessを起動し、Library > Installedタブを開きます。
-
問題となっている製品までスクロールし、製品項目の右側にある3つのドットメニューからReinstallを選択します。
注意:オリジナルのNative Access(ライトバージョン)をご使用の場合は、こちらの記事をご参照ください。
- 完了後、Maschineを再起動し、ブラウザからプリセットのロードをお試しください。
それでも同じエラーメッセージが表示される場合は、次章にお進みください。
MaschineのVSTファイルパスを確認する
プラグインがインストールされているフォルダにMaschineがアクセスしていることをご確認ください。 MaschineのPreferencesで正しい場所を設定するために、Native Accessを使用してVSTプラグインフォルダを確認することができます。
- Native Accessを起動してLibrary > Installedタブを開き、問題となっている製品項目を見つけます。
-
製品項目の右側にある3つのドットメニューからInstallation Pathsを選択します。
注意:オリジナルのNative Access(ライトバージョン)をご使用の場合は、こちらの記事をご参照ください。
-
VST Location (64 bit)の下に、プラグインがインストールされたフォルダが表示されます。
- Maschineを起動し、Preferences > Plug-ins > Locationsを開きます。
- VSTフォルダのパスがリストにない場合は、Addをクリックしてプラグインフォルダの場所を参照します。
- Rescanをクリックして、Maschineがプラグインを検索できるようにします。
それでも同じエラーメッセージが表示される場合は、次章にお進みください。
MaschineのデータベースとFavoritesをリセットする
上記手順を実行しても問題改善されない場合は、Maschineのデータベースをリセットすることをお勧めします。
- 以下の手順を実行する前に、Maschineおよび他のすべてのアプリケーションが起動していないことをご確認ください。
-
画面左下にあるWindowsスタートボタンをクリックして検索バーに%localappdata%と入力し、Enterキーを押します。これにより、コンピュータ上で以下の場所にあるフォルダが開きます:
C: > ユーザー > *ユーザー名* > AppData > Local - この場所(Local)から、Native Instrumentsを参照します。
-
ここにあるMaschine 2 / 3という名前のフォルダを削除してください。
- 続いてMaschineで使用されているFavoritesデータベースファイルを削除します。
注意:削除する前に、Favoritesファイルのバックアップコピーを保存することをお勧めします。
先ほどと同じ場所(C: > ユーザー > *ユーザー名* > AppData > Local)から、Native Instruments> Sharedを参照します。 - Sharedにあるfavorites.db3という名前のファイルを削除します。
-
Maschineソフトウェアを再起動し、データベースが再構築されるまでお待ちください。すべてのコンテンツがブラウザに再表示されるまでに時間がかかる場合があります。
- 完了後、Maschineのブラウザからプリセットのロードをお試しください。
これらのトラブルシューティングを実行すると、Maschineブラウザ内からプリセットをロードできるようになるはずです。