症状
Native Instrumentsアプリケーションが起動時にクラッシュしてしまう。
注意:Native Accessを開こうとしたときにクラッシュまたはフリーズする場合は、こちらの記事をご参照確ください。ただし、以下の情報を使用して、Native Accessの起動の問題をさらにトラブルシューティングすることも可能です。
原因
この問題には様々な要因が考えられます。このトラブルシューティング手順は、macOSシステムでのNIソフトウェアの起動クラッシュに対する最も一般的な解決策を示しています。
解決策
1. フルディスクアクセスを有効にする
NIアプリケーションを正しく動作させるために、フルディスクアクセスを許可する必要がある場合があります。フルディスクアクセスの詳細については、Apple社ウェブサイトをご参照ください。
- Macのシステム環境設定を開き、セキュリティとプライバシーをクリックします。
- プライバシータブで、サイドバーからフルディスクアクセスを選択します。
- 画面左下にある鍵アイコンをクリックして、macOSのパスワードを入力します。
-
NIアプリケーションがリストに表示されていることをご確認ください。
このリストに表示されていない場合は、+アイコンをクリックしてNIアプリを以下の場所から追加してください。この例ではMaschine 2を追加しています:
Macintosh HD: アプリケーション > Native Instruments > Maschine 2 > Maschine 2.app. - 設定完了後、鍵アイコンを再度クリックします。
2. ユーザ設定(PLIST)ファイルを削除する
-
コンピュータの以下の場所を開きます:
Macintosh HD > ユーザ > "ユーザ名" > *ライブラリ > Preferences
*注意:ユーザライブラリはmacOSの隠しフォルダです。このシステムの非表示の場所にアクセスする手順については、こちらの記事をご参照ください。
-
この場所にあるPreferencesフォルダを検索し、クラッシュしているNI製品のplistファイルを見つけます。plistファイルは以下の形式で名前が付けられています:
com.native-instruments.<製品名>.plist -
クラッシュしているNI製品のplistファイルのみを削除してください。
注意:他のplistファイルを削除してしまうと、別のアプリケーションで予期しない動作が発生する可能性があります。
- NIアプリケーションを起動し、問題が解決されたかご確認ください。
3. アプリケーションデータベースを再構築する
-
以下の場所を開きます:
Macintosh HD > ユーザ > "ユーザ名" > *ライブラリ > Application Support > Native Instruments
*注意:ユーザライブラリはmacOSの隠しフォルダです。このシステムの非表示の場所にアクセスする手順については、こちらの記事をご参照ください。
- この場所にあるNative Instrumentsフォルダを検索し、クラッシュしているNI製品のフォルダを見つけます。
-
クラッシュしているNI製品のフォルダのみを削除してください。
注意:他のNI製品フォルダを削除してしまうと、別のアプリケーションで予期しない動作が発生する可能性があります。
- NIアプリケーションを起動し、問題が解決されたかご確認ください。
4. NIソフトウェアをアンストールした上で再インストールする
上記の解決策で問題が解決しなかった場合は、クラッシュしているNIソフトウェアを完全にアンインストールした上で再インストールしてみてください。
注意:アンインストール/再インストールは、DAWプロジェクトや保存された書類には影響しません。 また同じコンピュータに再インストールしても、許可される認証数には影響しません(詳細については、こちらの記事をご参照ください)
-
クラッシュしているNIソフトウェアアプリケーションを手動でアンインストールする詳細な手順については、こちらの記事に従ってください。
注意:一般的な問題のほとんどのケースにおいて、Kontaktの大容量ライブラリをアンインストールする必要はありません。問題がライブラリの内容自体と関係したものでなければ、ライブラリ自体は削除せずにそのままにしておく事が可能です。
- NIアプリケーションをアンインストール後、Native AccessのAvailableタブから再インストールしてください。