Native Access Permission denied on OSX 10.13 [de]

注目の投稿 Answered

コメント

11件のコメント

  • Avatar
    Michi @ NI

    Hi,

    for some reason, the Native Access Helper Tool can not be installed or updated. Please do the following:

    Move the following files to the trash and empty the trash afterwards:

    • Macintosh HD > Library > Launchdaemons > com.native-instruments.NativeAccess.Helper.plist
    • Macintosh HD > Library > Privilegedhelpertools >com.native-instruments.NativeAccess.Helper
    • Macintosh HD > Application > Native Access.app

    (Note, maybe only one file is located on your computer)

    Then delete the PLIST file for NATIVE ACCESS:

    • Macintosh HD > User > *Username* > Library > Preferences > com.native-instruments.Native Access.plist

    Note: Since Mac OS 10.7 (Lion), the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu.

    Since OS X 10.9 (Mavericks) it is necessary to restart your computer after deleting the above-mentioned files to make the changes permanent.

    Now restart your computer. Afterwards please download the latest version from here and start the install process again.

    Please tell me if the problem persists

    Thanks in advance.

    Michi

  • Avatar
    michi knop

    Hi Michi,

    thanks, it worked!

    Best

     

  • Avatar
    Michael Schapiro

    Not working for me. Done these steps a total of 15 times, still getting 'permission required' in the Native Access app. I am /exceedingly/ frustrated.

  • Avatar
    Kerry Muzzey

    Same here:  I got "download failed" when it launched its auto update, then found the list of files I needed to delete from a post in this forum - then it seemed to launch but I also hit the permissions issue above and this didn't solve it. Well it sort of did: it got past the permissions issue and then ran right into the "download failed" issue described elsewhere in the forum. I'm stuck.

    Mac El Capitan here.

     

    Kerry

  • Avatar
    Manfred Nostitz

    vielen lieben dank hat super geklappt

  • Avatar
    Alex Toledo

    The Same Problem on MacOs Mojave. I Want My Money Back !

  • Avatar
    David Leija

    Same problem here as well. I followed those steps but it didn't work.

    OSX El Capitan

  • Avatar
    marcos larios

     Mac book pro was updated to macOS Mojave version 10.14.3
    Both the Mac book and DJ program Traktor are not connecting audio via usb to a DJM 900 nxs2.

    How can I fix this?

  • Avatar
    Jonathan Ouin
    I have the same problem as the original poster.
     
    I am running OS 10.13.6 High Sierra
     
    After installation of Native Access, I attempt to load it. It asks for my Mac admin password. I enter my Mac password, and it appears to accept it (as I would expect), but Native Access doesn't then prompt me for NI credentials. It simply says "Native Access requires your permission to run. Please click Retry and enter your password".
     
    When I click retry it goes back to the admin password entry as before. It is not asking for the NI password (I tried entering this and the window "shakes", as is the case when a password is entered incorrectly).
     
    I have carried out the steps outlined above - deleted all the files, trashed them, re-started my computer, reinstalled the software, but still the same.
     
    Would you be able to help me? It is preventing me from accessing instruments that I have purchased, which is obviously inconvenient.
     
    Thanks in advance for your help!
     
    Jon
  • Avatar
    Jonathan Ouin (編集済み )
     

     

  • Avatar
    N/A N/A

    hey also after upgrading from Sierra to Mojave native access can't open anymore bringing the same error above of "permission denied"

    I've tried the steps provided above several times but still nothing changes, and the problem has persisted

    please NI support help me fix this issue.

ログインしてコメントを残してください。