症状
在演奏您的 Komplete Kontrol S-系列键盘时,您无法听到任何声音,并且在 Komplete Kontrol 偏好设置中不能将您的键盘设置为 MIDI 设备。
原因
此问题可能由以下原因引起:
- NIHardwareAgent 和/或 NIHostIntegrationAgent 服务并未运行。
- 键盘的 MIDI 输入端口被关闭。
- 键盘并未正确进行连接。
- 仅适用于 Mac 系统:一个在 HAL 文件夹中的插件可能禁止了键盘被识别。
- 仅适用于 Windows 系统:未正确安装键盘驱动程序。
解决方法
请按照以下步骤解决问题:
- 请确保 NIHardwareAgent 和 NIHostIntegrationAgent 服务正在您的计算机上运行。请按照以下步骤在 Mac 或 Windows 中进行操作:
Mac
- 打开您的 Mac 的系统偏设置并选择 用户与群组(Users & Groups) > 登录项(Login Items)。
- 如果列表中缺少 NIHardwareAgent 和/或 NIHostIntegrationAgent 文件,请单击 ”+“ 图标并导航到以下位置来添加文件:
Mac HD > 资源库(Library) > Application Support > Native Instruments > Hardware - 请选择缺少的服务,并点击 添加(Add):
请注意:您可以通过按住计算机键盘上的 SHIFT 键并单击这两个文件来同时选择这两个文件。
Windows
- 请打开 Windows 的 任务管理器(Task Manager)并选择 服务(Services)选项。
请注意:如果 服务(Services)选项不能直接使用,请单击窗口左下角的 “更多信息(More details)” 以展开视图进行选择。
- 请搜索列表并检查 NIHostIntegrationAgent 和 NIHardwareService 服务的 状态(Status)是否为 正在运行(Running):
- 如果并没有运行,请右键单击对应的选项,然后从右键菜单中选择 开始(Start):
- 打开您的 Mac 的系统偏设置并选择 用户与群组(Users & Groups) > 登录项(Login Items)。
- 激活键盘的 MIDI 输入端口:
- 请打开 Komplete Kontrol 的 偏好设置(Preferences),并在 MIDI 选项卡中选择 输入(Input)。
- Mac: 请确保输入已激活。如果未选中输入,请单击对应选项左侧的方框以激活输入:
- Windows: 请确保输入已激活。如果未选中输入,请单击对应选项左侧的方框以激活输入:
- 如果仍可用,请确保使用键盘附带的原装 USB 线缆。将线缆直接连接到计算机。如果您必须使用一个 USB 集线器,请务必确保使用一个带供电的集线器。
- 仅适用于 Mac : 要确定 HAL 文件夹中的插件是否阻止了键盘被计算机识别,请按照 这篇文章 中的说明进行操作。
- 仅适用于 Windows: 请确保已经正确安装了键盘的驱动程序,请按照 这篇文章 中的第二章节和第三章节中的说明进行操作。