症状
Native Instruments 软件应用程序在启动时崩溃。
注意:如果在尝试打开 Native Access 时崩溃或冻结,请查看 这篇文章。 但是,以下信息也可用于进一步解决 Native Access 启动问题。
原因
这种行为可能有不同的原因造成。下面这些故障排除步骤列出了 Windows 计算机上 NI 软件启动崩溃的最常见解决方案。
解决方案
单击以展开下面列出的解决方案。
1. 删除用户注册表项(User Registry Entry)
- 单击屏幕左下角的 Windows 开始按钮。
- 在搜索字段中键入“regedit”,然后按 Enter 打开 Windows 注册表编辑器(Registry Editor)。
- 在注册表编辑器中,将文件夹结构导航到此位置并找到崩溃的 NI 产品的文件夹:
HKEY_CURRENT_USER > Software > Native Instruments > *产品名称* 文件夹
- 仅删除崩溃的 NI 产品的文件夹。
注意:删除不正确的文件夹可能会导致其他应用程序以及您的操作系统出现意外行为。
- 关闭注册表编辑器并重新打开您的 NI 软件以检查问题是否已解决。
2. 重新初始化应用程序数据库
- 在 Windows 文件资源管理器中,转到以下位置:
C: > Users > "您的用户名" > AppData > Local > Native Instruments
注意:“AppData”是一个隐藏的 Windows 文件夹。有关显示隐藏的 Windows 文件夹的说明,请参阅本文。
- 搜索此位置的 Native Instruments 文件夹以查找崩溃的 NI 产品的文件夹。
- 仅删除崩溃的 NI 产品的文件夹。
注意:删除其他 NI 产品文件夹可能会导致其他应用程序出现意外行为。
- 重新打开您的 NI 软件以检查问题是否已解决。
3. 更新 Windows
- 单击屏幕左下角的 Windows 开始按钮。
- 在搜索字段中输入“windows 更新”,然后按 Enter。
- 安装 Windows 更新菜单中显示的所有可用更新。
- 安装所有 Windows 更新后,重新启动计算机。
- 重新打开您的 NI 软件以检查问题是否已解决。
4. 更新显卡驱动
检查显卡更新的最快方法是在制造商的网站上。要查找显卡的名称和型号,请按以下步骤操作:
- 单击屏幕左下角的 Windows 开始按钮。
- 在搜索字段中输入“设备管理器”,然后按 Enter。
- 双击列表中的显示适配器(Display adapters)以打开下拉菜单。
注意:在上面的示例中,我们看到计算机具有 Intel (R) HD Graphics 3000 显卡。
- 访问您的显卡制造商的网站(在本例中为英特尔)。
- 从制造商的网站上,为您的显卡型号下载并安装最新的驱动程序。
- 更新显卡驱动程序后,重新打开 NI 软件以检查问题是否已解决。
5. 显示器设置
在极少数情况下,显示监视器的屏幕设置可能会导致 NI 软件应用程序出现问题。
- 如果使用两个显示器屏幕,请尝试断开其中一个与计算机的连接。
-
使用主监视器的默认缩放比例。
注意:如果缩放比例配置得太高,这可能会阻止 NI 应用程序打开。
现在,按照以下步骤配置监视器缩放:
- 单击屏幕左下角的 Windows 开始按钮。
- 在搜索字段中输入“设置”,然后按 Enter。
- 在“设置”应用中,选择“系统”。
- 在左侧面板上,单击显示。
- 在比例和布局(Scale and layout)部分下,使用下拉菜单选择标有:100%(推荐)的比例设置
- 重新打开您的 NI 软件以检查问题是否已解决。
6. 防病毒设置
在极少数情况下,防病毒软件可能会干扰 NI 应用程序的启动。 尝试暂时禁用防病毒软件,或尝试将您的 NI 应用程序添加到防病毒程序的例外列表中。
注意:如果需要进一步的配置帮助,请检查您的防病毒软件的文档,或联系防病毒制造商。
对防病毒软件进行必要的调整后,请重新打开 NI 软件以检查问题是否已解决。
7. 管理员模式
根据 Windows 系统的设置,可能需要在管理员模式下打开应用程序。 请继续执行以下步骤:
- 右键单击桌面上的 NI 应用程序图标,或程序文件夹中的应用程序图标 (.exe):
C: > Program Files > Native Instruments - 选择属性。
- 在兼容性选项卡上,勾选旁边的框:以管理员身份运行此程序
- 单击“确定”进行确认。
- 现在,NI 软件将始终以管理员模式运行。 重新打开您的 NI 软件以检查问题是否已解决。
8. 声卡设置
如果您尝试使用计算机内置声卡的驱动程序启动 NI 软件,同时为声卡的各个输出设置不同的采样率,则您的 NI 软件可能会崩溃。
确保声卡的所有单独输入和输出的采样率设置相同:
- 单击屏幕左下角的 Windows 开始按钮。
- 在搜索字段中输入“声音设置”,然后按 Enter。
- 在左侧面板上,单击声音(Sound)(见下文)。
- 从输出(Output)下拉菜单中选择您的主声卡或音频接口设备。在本例中,使用了 Komplete Audio 6 MK2。
注意:请务必对“输出”下拉菜单中的所有条目(如果存在)执行这些步骤,因为这些单独的条目代表声卡/音频接口设备上可用的所有输出。
- 单击您选择音频接口的下拉菜单下方的设备属性(Device Properties)。
- 在设备属性页面上,单击其他设备属性(Additional device properties)。
- 在弹出窗口(例如:输出 1/2 属性)中,单击高级选项卡(Advanced tab)。
- 检查采样率。此处,采样率设置为 2 通道、24 位、44.100 Hz(录音室质量)。做出选择后,单击“确定”。
- 返回主声音设置页面,对输出下拉菜单中的所有剩余设备条目重复此过程(上面的步骤 4-8)。 确保为所有输出和声卡设备选择完全相同的采样率设置。
- 配置所有输出条目后,对主声音设置页面上的所有输入条目重复整个过程。
- 重新打开您的 NI 软件以检查问题是否已解决。
9. 更新声卡/音频接口驱动程序
通过检查制造商的网站以获取最新可用的驱动程序和固件,确保声卡的驱动程序(可能还有固件)是最新的。
安装驱动程序后,重新启动系统并重新打开 NI 软件以检查问题是否已解决。