症状
启动 Logic Pro X 时,出现以下错误消息:
Incompatible Audio Units found.(找到不兼容的音频插件。)
原因
由于激活文件损坏,NI 插件无法通过 Logic 的插件管理器验证。
解决方案
1. 检查更新
启动 Native Access 并检查更新。如果有任何产品更新可用,请安装它们。还要确保安装了最新的 Logic Pro 更新。
2. 允许 Logic Pro 进行完整磁盘访问
请授予 Logic Pro 完整磁盘访问(Full Disk Access)权限。 您可以在本文中找到更多信息和说明。
3. 重新扫描和验证插件
- 向 Logic Pro 授予完整磁盘访问权限后,重新启动 Logic,并在出现错误信息时点按“启动插件管理器(Start Plug-In Manager)”。 您还可以从 Logic 任务栏打开 Logic 插件管理器(Logic Plug-In Manager)。
- 滚动以突出显示受影响的插件,然后单击重置和重新扫描选择(Reset & Rescan Selection)。
- 关闭 Logic 的插件管理器并重新加载您的工程。
您的 Native Instruments 插件现在应该可以在 Logic Pro 中使用了。 如果问题仍然存在,请继续执行下面的下一部分。
4. 进一步故障排除
出现错误消息时,单击启动插件管理器(Start Plug-In Manager)。这将显示哪些插件未通过验证。请注意在插件管理器中列为 验证崩溃(crashed validation)的 Native Instruments 插件。 在这个例子中,它是 Maschine 2。
请按照以下步骤解决问题:
- 在您的计算机上打开以下位置:
Macintosh HD > Users > *用户名* > Library
注意:有关在 macOS 上访问隐藏的用户库文件夹的说明,请参阅本文或下面的视频。
- 从以下位置删除受影响插件的产品文件夹:
Macintosh HD > Users > *用户名* > Library > Application Support > Native Instruments > *产品名称* folder - 从以下位置删除受影响插件的 plist 文件:
Macintosh HD > Users > *用户名* > Library > Preferences > com.native-instruments.*产品名称*.plist - 从以下位置删除缓存文件:
Macintosh HD > Users > *用户名* > Library > Caches > AudioUnitCache > com.apple.audiounits.cache - 清空您的系统垃圾并重新启动计算机。
- 打开 Logic 并允许它重新扫描所有 AU 插件。
注意:用户库(User Library)是 macOS 上的隐藏文件夹。要访问它,请单击 Finder 菜单栏中的“Go”并按住“Alt”键。库(Library)条目现在将出现在菜单中。