症状
尝试从 Native Access 安装产品时,出现以下错误消息:
安装失败(Installation Failed)
macOS
原因
当 Native Access 没有必要的权限来完成安装时,会发生此问题。
解决方案
- 打开 Mac 的系统偏好设置,然后单击安全和隐私。
- 在 隐私 选项卡下,从侧面栏中选择 Full Disk Access。
- 单击窗口左下方的锁定图标,然后输入 Mac 密码。
- 确保 Native Access 和 NTKDaemon 出现在列表中。
如果它没有出现在此列表中,请单击 + 图标并添加以下位置:
- Macintosh HD > Applications > Native Access
- Macintosh HD > Library > Application Support > Native Instruments > NTK > NTKDaemon
如果您尝试安装 Komplete Kontrol 或者 Maschine,请同时从以下位置添加 NIHardwareAgent:
- Macintosh HD > Library > Application Support > Native Instruments > Hardware > NIHArdwareAgent - 完成后,再次单击锁定图标。
根据您使用的 macOS,界面可能会有所不同。如有疑问,请查阅如何在特定 macOS 上打开“全磁盘访问”。较新的版本如下所示: -
重新启动计算机并启动 Native Access。
安装现在应该可以正确运行。
Windows
原因
此问题可能由 Windows 系统上的多种不同问题引起。在本文中,我们将介绍一些最常见的原因。
解决方案
使用了不正确/不受支持的文件路径
此问题的常见原因是在 Native Access 偏好设置中添加了不受支持的文件路径。要测试此问题,请尝试以下操作:
- 在 Native Access 中,打开 Preferences > File Management。
- 点击 Restore Defaults。
- 关闭 Preferences 并再次尝试安装。
如果安装现在按预期运行,则可能是所选文件路径不正确,或者之前选择的位置无法写入。这可能是由于外部驱动器格式错误/损坏,或权限问题造成的。
通过 Native Access 安装时,请务必确保选择安装到文件夹,而不是根驱动器位置。例如,安装到 D:\ 将无法正常工作,而安装到 D:\NI Libraries 则应该可以正常工作。
还请确保 应用程序位置(Application Location)始终保留为默认位置 C:\Program Files\Native Instruments\ - 我们不支持更改此位置。
先前的安装已损坏
如果产品安装在完成之前被中断并且安装程序无法卸载以前的版本,通常会发生这种情况。
解决此问题的步骤请参阅以下指南。请将以下步骤应用于您尝试安装的产品:修复软件更新安装问题(Windows)
然后尝试通过 Native Access 再次安装。
Windows 安装已损坏/损坏或缺少必要的文件
有时,Windows 安装可能会损坏或崩溃,导致安装失败和一般使用问题。在这种情况下,可以使用 Microsoft 提供的以下工具进行检查或修复:
尝试手动下载并运行安装程序
如果问题仍然存在,请尝试通过我们的新下载管理器手动下载并运行安装程序。
手动运行安装程序后,再次打开 Native Access 以激活产品。