症状
尝试使用 Native Access 安装产品或更新时,会显示以下消息:
Waiting for connection(等待连接)
注意:该消息也可能仅显示为 正在等待(Waiting )(取决于您在 Native Access 中选择的视图)。
原因
此问题通常是由以下因素之一干扰 Native Access 与我们服务器的连接引起的:
- VPN / 代理
- 网络安全软件/设置
- 防毒软件
解决方案
通常,禁用上述软件可以解决问题。
如果问题仍然存在,为了缩小问题的原因,请尝试暂时连接到个人热点:如何设置 Wi-Fi 热点以在离线计算机上激活 Native Instruments 产品
然后尝试开始下载。您可以在它成功启动后取消它以保存您的数据。
如果下载成功开始,则问题肯定是由您的网络/互联网设置中的上述因素引起的。
下面是更详细的步骤:
1. 使用了不受支持的 VPN 网络
如果您使用 VPN 客户端,请在运行 Native Access 时尝试将其禁用。
2. 防病毒软件阻止 Native Access
如果在从 Native Access 下载产品时遇到问题,请尝试停用所有可能正在运行的防病毒程序。
3. 更改连接源
如果可能,请尝试连接到另一台路由器,因为路由器本身的某些设置可能会阻止 Native Access。您也可以尝试从 WIFI 切换到以太网网,反之亦然。设置热点还可以帮助确定路由器是否是问题的根源:
如何设置 Wi-Fi 热点以在脱机计算机上激活 Native Instruments 产品
4. 删除扩展名为“iso”或“aria”的文件
- 关闭所有应用程序,并保持 Native Access 处于打开状态。
- 单击 Native Access 左侧的 偏好设置(Preferences)。
注意:在原始 Native Access (浅色版本) 上,单击右上角的用户图标以选择 偏好设置(Preferences)。 - 确保将三个文件位置 Download,Application 和 Content 都设置为不同的文件夹。您可以根据需要通过单击相应位置旁边的 BROWSE 按钮来更改位置。点击 SAVE 以确认更改。
注意:将应用程序位置(Application location)更改为另一个文件路径可能会导致问题。我们建议将其保留为默认设置。 - 关闭 Native Access
- 打开您设置为“下载位置”的文件夹,然后删除扩展名为“iso”或“aria”的所有文件(参见下面的示例)。
- 重新启动您的计算机。
- 打开 Native Access,然后再次开始安装。
5. 在防火墙设置中启用端口 80 和 443
确保 端口 80 和 443 打开,并允许传入连接。您可以在防火墙设置中进行配置。
进一步的故障排除
请选择您使用的是 Mac 还是 Windows 计算机。
Mac
1. FileVault 已启用
请关闭 FileVault 以查看是否可以解决问题:
- 定位到 Apple 菜单>系统偏好设置,然后单击 安全性 或 安全性和隐私性。
- 点击 FileVault 标签。
- 通过单击左下角的锁定来解锁窗格,然后输入管理员用户名和密码。
- 点击 Turn Off FileVault.
然后尝试再次从 Native Access 下载产品。
2. MacKeeper / Mac Tonic / Mac Auto Fixer 等已安装
MacKeeper,Mac Tonic,Mac Auto Fixer 等程序使用的例程可能会在后台阻止 Native Access。我们建议您在使用 Native Instruments 产品时从系统中卸载工具。
3. 防火墙阻止 Native Access
请尝试禁用防火墙,以便为 Native Access 授予下载产品所需的权限。
请按照以下步骤禁用防火墙:
- 定位到 Apple menu > System Preferences.
- 点击 Security 或者 Security & Privacy.
- 点击 FileVault 标签。
- 通过单击左下角的锁定来解锁窗格,然后输入管理员用户名和密码。
- 点击 Turn Off Firewall.
禁用后,请尝试再次从 Native Access 下载产品。如果您希望启用防火墙,请再次按照上述步骤操作,然后选择 Turn on Firewall。
同时也应禁用来自第三方开发人员的防火墙应用程序。
4. 正在使用代理服务器
请尝试禁用您的代理。
- 定位到 Apple menu > System Preferences.
- 选择 Network.
- 在左窗格中,选择要在其上禁用代理设置的网络服务,然后单击 Advanced... 按钮。
-
选择 Proxies 选项卡并取消选择 Select a protocol to configure 下的所有协议。
-
完成后单击 OK。
禁用后,请尝试再次从 Native Access 下载产品。如果您希望在下载完成后重新启用代理服务器,请重复上述步骤并在选择要配置的协议下重新启用所有协议。
5. 不支持的驱动器/文件格式
我们建议在 Mac OS X 10.12 及更早版本上使用 HFS + / Mac OS Extended(日志式)。在 Mac OS X 10.13 和更高版本上,建议使用 Apple File System(APFS)。这些是标准磁盘格式。
6. 文件位置
设置 Native Access 文件位置时,请注意其不支持 NAS 或云存储位置。请参阅本文以了解有关 Native Access 文件位置的更多信息。
7. 禁用 iCloud Private Relay(仅限 macOS 12 Monterey)
macOS 12 (Monterey) 提供了所谓的 iCloud Private Relay 服务(测试版),让您可以更安全地连接到网络。我们建议在安装 NI 产品时禁用此服务:
- 打开 Mac 的 系统偏好设置 > 网络。
- 在边栏中选择您的 Wi-Fi 或以太网连接。
- 要关闭 iCloud Private Relay,请取消勾选 限制 IP 地址跟踪框(Limit IP Address Tracking)。
Windows
1. 防火墙阻止 Native Access
请按照以下步骤禁用 Windows Defender 防火墙:
- 点击屏幕左下方的 Windows 图标,然后输入“Windows 防火墙''。
- 在搜索结果中单击 Windows Defender 防火墙。
- 在菜单窗格中,选择 打开或关闭 Windows Defender 防火墙。
- 为两个网络(私有和公共)选择 关闭 Windows Defender 防火墙。
尝试再次从 Native Access 下载产品。下载后,我们建议重新启用 Windows Defender 防火墙。
同时也应禁用来自第三方开发人员的防火墙应用程序。
2. 正在使用代理服务器
- 点击屏幕左下方的 Windows 图标,然后输入“代理”。
- 在搜索结果中单击“更改代理设置''。
- 将选项 自动检测设置 切换为 开启。
- 将选项 使用代理服务器 切换为 关闭。
禁用后,请尝试再次从 Native Access 下载产品。
3. Windows 用户临时文件夹有缺陷
请仔细按照以下步骤操作,以删除 User Temp 文件夹的内容:
- 导航到系统上的以下位置:
C: > Users > *用户名* > AppData > Local > Temp注意:默认情况下,该临时文件夹是隐藏的。在本文中了解如何显示隐藏的文件和文件夹。
- 通过按键盘上的 Ctrl + A 选择 Temp 文件夹中的所有文件和文件夹。
- 右键单击并从上下文菜单中选择“删除'',以删除所有选定的项目。请注意,某些文件和文件夹无法删除。
完成上述步骤后,请尝试再次从 Native Access 下载产品。
4. “下载 Download” 或 “内容 Content”位置不支持的驱动器/文件格式
我们建议使用 NTFS 格式。这是 Windows 计算机上的标准磁盘格式。
5. 文件位置
设置 Native Access 文件位置时,请注意其不支持 NAS 或云存储位置。请参阅本文以了解有关 Native Access 文件位置的更多信息。