症状
Native Instruments 应用程序在启动时崩溃。
注意:如果尝试打开 Native Access 时它崩溃或死机,请检查本文。但是,下面的信息也可以用于进一步解决 Native Access 启动问题。
原因
此行为可能有不同的原因。这些故障排除步骤列出了 macOS 系统上 NI 软件启动崩溃的最常见解决方案。
解决方案
1. 启用全盘访问 (Full Disk Access)
可能需要授予对您的 NI 应用程序的全盘访问权限才能使其正常工作。有关全盘访问的更多信息,请访问 Apple 网站。
- 打开 Mac 的系统偏好设置,然后单击安全和隐私。
- 在“隐私”选项卡下,从侧栏中选择“全盘访问(Full Disk Access)”。
- 单击窗口左下方的锁定图标,然后输入您的 macOS 密码。
- 确保您的 NI 应用程序出现在列表中。
如果它没有出现在此列表中,请单击 + 图标并添加您的 NI 应用程序的位置。 在本例中,我们从以下位置添加 Maschine 2:
Mac HD: Applications > Native Instruments > Maschine 2 > Maschine 2.app. - 完成后,再次单击锁定图标。
2. 删除用户偏好设置(PLIST)文件
- 前往您的计算机的以下位置:
Macintosh HD > Users > "您的用户名" > *Library > Preferences
*注意:用户资源库(Library)是 macOS 上的隐藏文件夹。请参阅 本文,以获取访问此隐藏系统位置的说明。
- 在此位置搜索 偏好设置(Preferences)文件夹,以查找崩溃的 NI 产品的 plist 文件。plist 文件将以以下格式命名:
com.native-instruments.<产品名称>.plist - 仅删除崩溃的 NI 产品的 plist 文件。
注意:删除其他 plist 文件可能导致其他应用程序出现意外行为。
- 重新打开 NI 应用程序以检查问题是否已解决。
3. 重新初始化应用程序数据库
- 前往以下位置:
Macintosh HD > Users > "您的用户名" > *Library > Application Support > Native Instruments
*注意:用户资源库(Library)是 macOS 上的隐藏文件夹。请参阅 本文,以获取访问此隐藏系统位置的说明。
- 在此位置的 Native Instruments 文件夹中进行搜索,以查找崩溃的 NI 产品的文件夹。
- 仅删除崩溃的 NI 产品的文件夹。
注意:删除其他 NI 产品文件夹可能会导致其他应用程序发生意外行为。
- 重新打开 NI 应用程序以检查问题是否已解决。
4. 删除并重新安装 NI 软件
如果上面列出的解决方案不能解决问题,请尝试完全删除并重新安装崩溃的 NI 软件。
注意:卸载/重新安装 不会影响您的 DAW 项目工程或保存的文档。重新安装到同一台计算机上不会影响您允许的授权数量(有关更多信息,请参阅本文)。
- 请按照本文获取详细说明,以手动删除崩溃的 NI 软件应用程序。
注意:在大多数情况下,无需卸载 Kontakt 或大型采样音色库文件夹即可解决常见问题。您可以安全地将采样库文件夹保留在适当的位置。
- 删除 NI 应用程序后,可以从 Native Access 的“未安装(Available)”选项卡中重新安装它。