Native Access error: "Library path is not valid. Please browse again."

置顶的 被推荐的 Answered

评论

63 条评论

  • 正式评论
    Avatar
    Jeremy @ NI (已编辑于 )

    Hello peeps,

    We now have a knowledge base article covering the issue :

    Native Access Error Message: "Library path is not valid. Please browse again."

     
    评论操作 固定链接
  • Avatar
    Michi @ NI

    Hi,

    could you show us a screenshot of the error message which appears?

    Thanks,

    Michi

    -1
    评论操作 固定链接
  • Avatar
    Patrick Shanahan

    I have the exact same problem with Spitfire Audio Chamber Strings

    0
    评论操作 固定链接
  • Avatar
    henk van ess

    I have the same problem with Epica. How do I solve it?

    -1
    评论操作 固定链接
  • Avatar
    Jesse Jackson

    Same here but with everything. All codes are accepted fine, but the paths are coming up as invalid when asked which libraries to install. I'm gonna try someone's suggestion to install an older version of Kontakt to bypass the new system with NA then reinstall the newest version of Kontakt after. Wish me luck.

    1
    评论操作 固定链接
  • Avatar
    Mati Schwartz

    I'm having the same issue ... with Exhale :(

    0
    评论操作 固定链接
  • Avatar
    Tyler Solleder

    Same issue here with Akoustik Piano, Elektrik Piano and Elektrik Piano 1.5

    0
    评论操作 固定链接
  • Avatar
    Mati Schwartz (已编辑于 )

    Ok, I solved mine (Exhale)

    You have to make sure that your folder structure is organized in a certain way.

    When output hub installed the files, it did not organize them in the right way for Kontakt to read them.

    Below is a screen grab of how I organized the Exhale folder before directing Kontaks to the relevant sections which solved the problem. (You need to batch save via Kontakt stand alone after adding the library and before opening it in any DAW).



    1
    评论操作 固定链接
  • Avatar
    henk van ess

    I found the solution for my problem, credit to Jack of Zero-G Support. 

    As for Native Access to recognise it, you need to click on the mother folder first and this will recognise the path which you finally can click on. It can be a bit glitchy.

     

    -5
    评论操作 固定链接
  • Avatar
    Gregory Moore

    Why is my path invalid?  How can I fix it?

    0
    评论操作 固定链接
  • Avatar
    Heikki Niemelä

    I have same problem. All 3rd party serials go in fine but can not select path to install.

    same message as in the message above.

    for altus, shevannai, aeon melodic, aeon rythmic, shreddage II ..

    -1
    评论操作 固定链接
  • Avatar
    David Darby

    I am having the same problem with a couple of SoundIron libraries.  I guess NA is not interested in helping out. Crickets abound!

    3
    评论操作 固定链接
  • Avatar
    Heikki Niemelä

    Yes I have paid 1000 + and no answer!

     

    However I found out what the problem is for me -

    And this was not obvious despite I am programmer, UX design, you name it, long time computer user etc.

     

    The installation folder selection for 3rd party plugins is NOT about selecting where to install, like with NI plugins.

    For 3rd party instruments it is the folder you have ALREADY installed the product.

     

    In other words, one has to download from 3rd party and extract / install whatever,

    then the install folder in Native Access is only about selecting the registered plugin folder to enable it.

     

    -2
    评论操作 固定链接
  • Avatar
    Randall Arnold (已编辑于 )

    I'm getting the error even on products installed (Heavyocity, Scoring Guitars)

    1
    评论操作 固定链接
  • Avatar
    Chung Yi Chang

    Thanks to Heikki Niemelä.

    yes for products not belonging to NI (eg., Heavyocity, Spitfire....), you just need to browse the folder which you have already installed. 

    -2
    评论操作 固定链接
  • Avatar
    Werner M. Weidensdorfer

    Same problem here with Indigisounds samples. Could anyone please tell me what "then the install folder in Native Access is only about selecting the registered plugin folder to enable it." means?

    0
    评论操作 固定链接
  • Avatar
    Werner M. Weidensdorfer

    OK , I found my solution. I looked for the *nicnt file. If you browse to the containing folder you are rewarded. :-)

    0
    评论操作 固定链接
  • Avatar
    Simon Paxton

    I am having a similar problem for EXHALE.  I got a new computer and transferred everything from my old computer via an external HD.  Now EXHALE is stuck in demo mode and Native Access says I need to repair it.  

    I click "repair".  It says "Native Access could not find the content for EXHALE.  You may have trouble using or updating this product."  

    I click "relocate".  It says "To relocate please browse to the folder where you unzipped EXHALE."  

    I click "browse".  

    I choose the file path and click "relocate".  

    It says "Installation failed. The selected library could not be installed."  

    Can anyone help me with this? 

    2
    评论操作 固定链接
  • Avatar
    N/A N/A

    I have the same problem as Simon Paxton above; is there any solution to this??

    0
    评论操作 固定链接
  • Avatar
    Michael Vitacco

    For those of you who've had problems installing even NI software: all you need to do is go to your Settings tab and change the filepath to your external drive there.  If you try to do it otherwise (i.e. by browsing per software bundle on the main page) you will get that error.

    0
    评论操作 固定链接
  • Avatar
    Isaak Millier

    same problem with GGD, just installed everything for the first time and doesn't work, but somehow the demo worked fine, just not once I start throwing money in...

    Library path is not valid, please browse again. 

    1
    评论操作 固定链接
  • Avatar
    Michi @ NI

    @Isaak, could you please send me a screenshot of the content. I should look more or like this:

     

     

    It is very important that the NICNT file (or for Kontakt 4 libraries - NKX files) is located in this folder.

    Have you also seen this video-guidance regarding adding the right folder?

    Setting up a Third Party KONTAKT Library [VIDEO]

    Thanks.

    0
    评论操作 固定链接
  • Avatar
    Michael Basson

    THIS MIGHT BE THE SOLUTION FOR EVERYBODY :

    I had the same problem, some libraries had the 'repair' triangle, I clicked on 'repair' and it asked me to browse to the location, but that just doesn't work (even I know it is the correct location) ! 

    By pure luck I noticed at the top of the Native Access application window, there are 3 symbols on the right  side:

    1st one the circle symbol consisting of two arrows that forms a circle, if you hover mouse over it, it will say "Refresh"

    2ne one : User login / logout

    3rd one : Native Instruments logo

     

    I clicked on the 'Refresh" button (1st one) and immediately all the repair issues just disappeared, all the problems solved!!

     

    Hope this helps you

     

    PS That's all I did , I didn't reorganize the library structure or library paths update like some other user reported here, just one click on the "refresh" button and all the repair issues were sorted out. 

    0
    评论操作 固定链接
  • Avatar
    Jose Cabrera

    I was having the similar problem with AEON Rhythmic.

    The folder path was correct (no path library warning in red letters) but the “Install” button was grayed out. I couldn’t install it until I realized that I had set the “Content Location” under “Preferences”, which you can access by clicking the User login icon on the top right corner of Native Access, the same as the path for AEON Rhythmic.

    Apparently this causes a conflict, so make sure to set your Content path to a different folder that’s NOT similar to the path of any of your sample libraries. You should now be able to install your libraries.

    HTH

    0
    评论操作 固定链接
  • Avatar
    Darren Perez

    I'm still having trouble installing Kontakt Factory Library. I set my installation path using the preferences on Native Access. It still says to free an additional 11 GB of space.

    I had the same problem with Una Corda and I freed up enough space on my internal Mac hard drive and it worked. Even though my installation path is set to my external drive and it shows downloaded on my external. I can't free up enough space to install the Factory Library(37 GB) though because my mac is only 120 GB and with nothing on it the system alone takes 86.04 GB of space.

    I also used the refresh button mentioned above. Running OS Sierra 10.12.5

    NI can you please advise?

    0
    评论操作 固定链接
  • Avatar
    Tebogo Bruce Sebitlo

    I've been having a similar problem with "Analog Strings"; but I just fixed it now. Michi is correct. The order is important. I've organized my Analog Strings folder as follows:

    - Documents

    - Instruments

    - Library

    - Samples

    - Snapshots

    - .nicnt File (Can be anywhere between the above sub-folders; depending on the plugin's name's alphabetical order.)

    Of course some of these sub-folders may not appear depending on what plugin you're trying to set the path for.

    In this way, NA will validate the path as it should.

    0
    评论操作 固定链接
  • Avatar
    Tyler Will

    Unfortunately none of those worked for me. I’m having the same problems as everyone else. All because I turned my external hard drive off. (The right way!) when I went to repair them, it couldn’t find the right place. So it’s now in the process of downloading already downloaded instruments on my hsrddrive again. Im still left with over 65 third party instruments that give me the error message “library path is not valid. Please browse again” even though I have changed nothing on ANY of my instruments. This is beyond frustrating and if there was anyway to completely switch from Kontakt/NI, I would. No responses to my questions and I’m stuck with $10000 of unusable instruments right now.

    1
    评论操作 固定链接
  • Avatar
    Philipp P. @ NI (已编辑于 )

    Hello everyone!

    It seems most of you have different issues setting up a Kontakt library from a third party developer (e.g. Output, Heavyocity, Indigisounds, Spitfire, Soundiron, etc.) located. There are various reasons why this can happen:

    1. Library from Third Party developer is not correctly installed
    2. Wrong folder selected in Native Access
    3. Security Software blocks installation (BitDefender antivirus free edition, Malwarebytes Anti-Malware)
    4. HD formatted in “case sensitive”

    You can try the following solutions in order to solve it:

    1. Make sure that you have installed the third-party library correctly (a library folder should be located on your hard drive, see the Knowledge Base article below for more information)
    2. Run through this guide: Setting Up a Third Party KONTAKT Library
    3. Deactivate Security Software temporarily (known apps are “Bitdefender Antivirus or Malwarebytes Anti Malware)
    4. Format HD in NTFS (for Windows mostly) or Mac OS Extended (Journaled) (alternatively: move the library to an HD with that format)

    If you found another solution yourself, feel free to post it here. I am happy to include it in this answer.


    Cheers,
    Philipp

    0
    评论操作 固定链接
  • Avatar
    Thomas Clement

    Nothings worked for me. All NI Komplete Ultimate libraries install and show up fine. Not a single non NI Kontakt library works, even after trying everything mentioned.

    0
    评论操作 固定链接

请先登录再写评论。