The screens of my Maschine controller stuck on "Maschine" and "Production and Performance System"

置顶的 被推荐的 Answered


9 条评论

  • 正式评论
    Niall @ NI (已编辑于 )


    please see the following:

    My MASCHINE Controller Does Not Start (Windows)


    My MASCHINE Controller Does Not Start (Mac)

  • Avatar
    D.G. B

    I am experiencing the same thing. I have been wondering how to get that to change

  • Avatar
    D.G. B

    Brandon Fraker,

    I downloaded the MK3 driver from the website and it worked out I now see the screen I should.Be sure to make sure the MK3 is not connected when you try that bro!

  • Avatar
    Sergio Pereira

    Hi Guys 


    So I bought my MASCHINE MK3 for Xmas this year, I'm running it along side a MACPRO LAPTOP 2018 (MOJAVE 10.14.2)

    Unfortunately I have the exact same problem as above Maschine gets stuck on  1st screen saying "Maschine" and the second screen saying "production and performance system" 

    I have read all the articles to resolve, Update Avid Drivers, Remove HAL Avid drivers ect...,Downloaded latest software, Downloaded latest Firmware Driver,

    still nothing

    Is the Problem solvable ? 



  • Avatar
    N/A N/A

    Same here....

    It even behaved like that without having had it connected to a PC at all....

    Out of the box, wired with the mains-outlet, it just gave me the two screens... and does so... forever if I'd like....
    No manufacturing date on the device itself to see - Not sure whether I ran into a bad batch or so...

    Even more curious: Meanwhile of course all the setup-routines on my Win10 Host are done.
    I'm sitting here with - ultimately RUNNING drivers (system sees MK3 as a working device) !Used the manual driver installation! - and a running MK3 Control Panel where it states that the audio device of my UBS-connected MK3 is working fine. Latencies lower than 30ms. So far so good... But really nothing else seems to work. NA doesnt provide MaschineII software.

    Any hints on the situation?

  • Avatar
    N/A N/A

    We are having the same problem. We purchased the MK3 as a Christmas present, but still cannot get it to work almost a week later.  We are using Windows and have followed all the steps to troubleshoot it, with no results.

    We don't know what else to try at this point. 

    Any suggestions are appreciated.   

  • Avatar
    N/A N/A

    Regarding my post, dated in here Dec. 24th:

    Happy to report that my issue has been solved.
    Within the last sentence I stated, that NI did not provide the MaschineII-Software. True for my situation. Although I got the unit as "brand new" from a retail store, me contacting NI Support via phone made clear: The unit is pre-owned. The issue that MaschineII for me wasnt available is tied to a missed out licence transfer.

    Meanwhile solved. MaschineII-Software is key to get things running - During installation another MIDI-Driver gets installed - After installation everything is up and running now; even Controller Editor.

  • Avatar
    David Dagostino (已编辑于 )

    I want to note that I would not lump this problem with your case of getting a used maschine mk3.   I have run into this problem, happened again this every moment, and I am 100% positive I have a brand new device.  I've had maschine 2 software since beginning.     I'm saying this only because I suspect this annoying bug can happen for more than one reason, and it is very doubtful there was any mass error on NI's part  in distributing used devices.

    Now all that said, this is the 2nd time it's happened to me, and I'm not quire sure what I did the first time to fix.   For me, the problem happens if I'm using Pro Tools, and I turn the mk3 off and then back on.   It gets completely stuck.    The last time I tried numerous things - use diff usb port, removed and reset the midi device (note I'm using a mac so this is done in Audio Midi Setup app).    All I know is after a restart, it started working again.

    I have been using this with Logic Pro X since I purchased in Novemeber and it has been mostly flawless.   I just recently switched back to Pro Tools because I read something about Logic AU plugins in that they cannot transmit midi (or receive), i forget, and. so I could not get tracks to capture the actual midi unless i put mk3 directly in midi mode.    I was trying to see if Pro tools would have similar problem.  Long story short, in my setup, the main problem. seems to happen only in a specific circumstance, one that I don't fully understand yet.


    UPDATE:  Since i speculated the issue was with pro tools somehow, instead of rebooting/etc, I closed pro tools and fired up Logic instead.  As soon as Logic loaded, I had a track in existing session with maschine 2 plugiin, and the hardware immediately moved past the frozen boot screen.    Sorry this doens't really answer any major questions, but wanted to share my findings. 

  • Avatar
    Niall @ NI


    this is a known issue with the latest version of Pro Tools.  Downgrading to the previous version will allow Maschine to work correctly again.  Avid are aware of the problem.