Native Access Permission denied on OSX 10.13 [de]

Answered

评论

17 条评论

  • Avatar
    Michi @ NI

    Hi,

    for some reason, the Native Access Helper Tool can not be installed or updated. Please do the following:

    Move the following files to the trash and empty the trash afterwards:

    • Macintosh HD > Library > Launchdaemons > com.native-instruments.NativeAccess.Helper.plist
    • Macintosh HD > Library > Privilegedhelpertools >com.native-instruments.NativeAccess.Helper
    • Macintosh HD > Application > Native Access.app

    (Note, maybe only one file is located on your computer)

    Then delete the PLIST file for NATIVE ACCESS:

    • Macintosh HD > User > *Username* > Library > Preferences > com.native-instruments.Native Access.plist

    Note: Since Mac OS 10.7 (Lion), the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu.

    Since OS X 10.9 (Mavericks) it is necessary to restart your computer after deleting the above-mentioned files to make the changes permanent.

    Now restart your computer. Afterwards please download the latest version from here and start the install process again.

    Please tell me if the problem persists

    Thanks in advance.

    Michi

    1
    评论操作 固定链接
  • Avatar
    michi knop

    Hi Michi,

    thanks, it worked!

    Best

     

    -1
    评论操作 固定链接
  • Avatar
    Michael Schapiro

    Not working for me. Done these steps a total of 15 times, still getting 'permission required' in the Native Access app. I am /exceedingly/ frustrated.

    3
    评论操作 固定链接
  • Avatar
    Kerry Muzzey

    Same here:  I got "download failed" when it launched its auto update, then found the list of files I needed to delete from a post in this forum - then it seemed to launch but I also hit the permissions issue above and this didn't solve it. Well it sort of did: it got past the permissions issue and then ran right into the "download failed" issue described elsewhere in the forum. I'm stuck.

    Mac El Capitan here.

     

    Kerry

    0
    评论操作 固定链接
  • Avatar
    Manfred Nostitz

    vielen lieben dank hat super geklappt

    0
    评论操作 固定链接
  • Avatar
    Alex Toledo

    The Same Problem on MacOs Mojave. I Want My Money Back !

    0
    评论操作 固定链接
  • Avatar
    David Leija

    Same problem here as well. I followed those steps but it didn't work.

    OSX El Capitan

    0
    评论操作 固定链接
  • Avatar
    marcos larios

     Mac book pro was updated to macOS Mojave version 10.14.3
    Both the Mac book and DJ program Traktor are not connecting audio via usb to a DJM 900 nxs2.

    How can I fix this?

    0
    评论操作 固定链接
  • Avatar
    Jonathan Ouin
    I have the same problem as the original poster.
     
    I am running OS 10.13.6 High Sierra
     
    After installation of Native Access, I attempt to load it. It asks for my Mac admin password. I enter my Mac password, and it appears to accept it (as I would expect), but Native Access doesn't then prompt me for NI credentials. It simply says "Native Access requires your permission to run. Please click Retry and enter your password".
     
    When I click retry it goes back to the admin password entry as before. It is not asking for the NI password (I tried entering this and the window "shakes", as is the case when a password is entered incorrectly).
     
    I have carried out the steps outlined above - deleted all the files, trashed them, re-started my computer, reinstalled the software, but still the same.
     
    Would you be able to help me? It is preventing me from accessing instruments that I have purchased, which is obviously inconvenient.
     
    Thanks in advance for your help!
     
    Jon
    0
    评论操作 固定链接
  • Avatar
    Jonathan Ouin (已编辑于 )
     

     

    0
    评论操作 固定链接
  • Avatar
    N/A N/A

    hey also after upgrading from Sierra to Mojave native access can't open anymore bringing the same error above of "permission denied"

    I've tried the steps provided above several times but still nothing changes, and the problem has persisted

    please NI support help me fix this issue.

    0
    评论操作 固定链接
  • Avatar
    David Wheeler

    I have downloaded and installed Native Access from NI site as directed.

    When I attempt to login I get a permission denied message despite using my correct password.

    Can someone please assist without asking me to supply details from my computer. I have paid considerable sum of money to purchase the Kontact Ultimate and Native Access was supposed to make access 'easy' and helpful. This is anything but.

    0
    评论操作 固定链接
  • Avatar
    Georgi Ivanov

    the same problem guys and two days i tray to fixing and still the same :((((

    -1
    评论操作 固定链接
  • Avatar
    Andrew Brook

    I have the same problem - interestingly I have a MBP with the same setup and that's working great with native Access.  But with my iMac the App bounces and then never appears.  It looks like Im having the same problem with Maschine 2.

    Any clues NI?

    0
    评论操作 固定链接
  • Avatar
    Michi @ NI

    In some cases, it helps to create a new OSX Admin User...

    Please tell me if the problem persists

    Thanks in advance.

    0
    评论操作 固定链接
  • Avatar
    Dennis Alfarez

    nothing works ,also this problem comes out of the blue. one day it's ok and the next day I'm having this permission issues.

    NI come with a solution please

    0
    评论操作 固定链接
  • Avatar
    Dennis Alfarez

    Also a thing I'm having trouble with native acces is that my installed products seems to be offline all the time and then I have to reconnect them to the map where they where installed in.

    Really weird 

    0
    评论操作 固定链接

请先登录再写评论。