Native Instruments Support Maschine

Maschine | MASCHINE+ Download Fails

Symptom

Downloading a NI product on MASCHINE+ fails, even after restarting the download procedure.


Cause

The MASCHINE+ could have momentarily lost connection to your WiFi and corrupted / incomplete files remain on your device.


Solution

In order to solve this issue, go through the steps below:


  1. Connect your MASCHINE+ to your computer using the provided USB cable.
  2. Press the [SETTINGS] button on your MASCHINE+.
  3. Use the 4-D encoder to select [System].
  4. Press Button 3 [STORAGE].
  5. Once the SD card appears as an external storage device on your computer desktop, navigate to the following folder: SD Card > Downloads > (*product name*)
  6. Delete the .nipkg and .aria2 files of the product that fails to be downloaded (e.g. lilacglare_2.0.2.1.nipkg and lilacglare_2.0.2.1.nipkg.aria2)
  7. Empty the trash bin and eject the SD card from your computer.
  8. Press Button 8 [DISCONNECT] to exit Storage mode.
  9. Reinstall the faulting product.


If the issue persists, ensure your MASCHINE+ is connected to the correct WiFi network:


  1. Press [SETTINGS].
  2. Using the 4-D encoder, select [Network].
  3. Turn the 4-D encoder or Knob 8 to select the name of the network you want to connect. If the name of the network you want to connect is not visible, press Button 7 [REFRESH].
  4. Press Button 8 [CONNECT].
  5. Enter your WiFi password by turning the 4-D encoder to navigate the characters.
  6. Press [ENTER] to confirm your password.


Note: it is possible to use a USB-to-Ethernet adapter and connect to your router directly to ensure a stronger connection to the Internet.