Native Instruments Support Native Access

I cannot find a product update in Native Access

Symptom:

Native Access does not display the latest product update


Cause:

Your operating system is not compatible with the product update. Native Access only displays updates that are compatible with your operating system version.


Solutions:

Please make sure that your operating system fulfills the system requirements for the product.

  • Windows: It is important to always install the latest Windows Update:
    Click the Windows Start button, and then go to Settings > Update & Security > Windows Update.
  • macOS: You can check the compatibility charts here: Compatibility of NI products on macOS


Please also make sure that you log in with the account that contains the license for the product you want to update.